0

I'm using Qualcomm Atheros AR938x Wireless Network Adapter with Windows 10 Pro x64 version 1803. Driver version: 10.0.0.355

I've tried toggling the "Allow the computer to turn off this device to save power" option in the adapter settings, but that doesn't seem to help the issue. I've tried resetting the adapter with practically every cli command known to the Windows world and I've tried disabling IPv6.

When I connect to a network, it appears that I'm connected in the system tray, but it takes about a minute or two before a connection to the internet is established.

Also, after the computer wakes from sleep, I have to wait the 1/2 minutes again, even though I've said in the driver settings not to turn the device off.

Windows network diagnosis states "Windows could not automatically detect this network's proxy settings." I have instructed Windows to detect proxy settings automatically in inetcpl.cpl's LAN settings, but this diagnosis persists.

Thanks.

1 Answer 1

1

We can try the following setting:

Step 1: Uninstall the network adapters we do not need.

Step 2: Set wireless network adapter.

1.View "Realtek RTL8188EE 802.11 bgn Wi-Fi Adapter", open control panel->System->Device Manager->Network adapters->Realtek RTL8188EE 802.11 bgn Wi-Fi Adapter (this is an example, we can select the wireless network adapter name with "Wi-Fi" or "wireless").

2.Right-click "Realtek RTL8188EE 802.11 bgn Wi-Fi Adapter", select " Properties".

3.Click "Advanced", in the "Property" box, select "802.11n channel width for 2.4GHz", in the "Value" box, select "20MHz Only";

In the "Property" box, select "HT mode", in the "Value" box, select "Enabled or HT mode 20 or HT Mode 20|40" and click "OK" (note: If you have default windows driver installed then you may have options in the dropdown like "HT Mode 20|40". If you found then select it).

HT mode: Allows you to specific which modes to support: High Throughput(802.11n) and/or Very High Throughput (802.11ac).

The dialog displays like this:enter image description here

If the way above does not work, in the following article, some people also encounter the same issue as you, we may refer their resolution.

WiFi very slow to reconnect (if at all) after sleep or hibernation

2
  • Why have you referred to a Realtek Adapter in your answer when I'm asking about an Atheros adapter? Jul 27, 2018 at 14:53
  • Because I have no the same configuration environment as you, the answer with "Realtek RTL8188EE 802.11 bgn Wi-Fi Adapter" mainly tells you that you need to select the wireless network adapter name with "Wi-Fi" or "wireless", no others.
    – Daisy Zhou
    Jul 30, 2018 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.