11

Is there a way to permanently disable the Google Chrome session restore (see screenshot)?

It appears at almost every system start. Not everytime, which makes it difficult to reproduce. Also, I could not notice any relation to whether there was a previous crash or not.

enter image description here

EDIT 1:

Version in use: Google Chrome 68.0.3440.75

  • Checking the report box might help for future versions ;) – Tetsujin Jul 25 '18 at 19:14
5

Chrome has a special flag to disable session restore window. But be aware options in chrome://flags are experimental and you may lose browser data or compromise your security or privacy.

Follow these steps:

  • Open Chrome.
  • Type chrome://flags/#infinite-session-restore in address bar (Crtl+L).
  • Click on the right drop-down menu and change the 'Default' value to 'Disable'. Then restart Chrome to apply that setting.

So what does this do? That option says -- "Reduces the number of tabs being loaded simultaneously during session restore, to improve responsiveness of the foreground tab". After disabling and restating Chrome, it relaunches chrome.exe with --disable-features=InfiniteSessionRestore option.

  • 7
    This option has been removed in chrome 74.0.3729.157 – woens May 21 at 11:11
  • 5
    If this option has been removed is there any other alternative, @Biswapriyo? – akabhirav May 21 at 21:04
2

Edit the file located at C:\Users\username\AppData\Local\Google\Chrome\User Data\Default

Right click "Preference" file and click edit. ctrl+f to find the following values, and change the value to:

"exit_type": "none",

"exited_cleanly":true,

Save the file, and change the attribute to "read only" so chrome can't change it back.

  • Running perl -pi -e 's/exit_type\":\"Crashed/exit_type\":\"none/' ~/.config/google-chrome/Default/Preferences does the trick for me on Ubuntu. Executing this whenever your graphical environment starts gets rid of the Chrome warning for good, without having to change the file to readonly. (Someone could make this an answer, I am lacking the rep …) – panepeter May 8 at 7:46
  • Thanks this seems to work more than one year later. – Snak3d0c Jun 20 at 7:34
  • @panepeter would this then disable the Restore functionality? What I want is for Chrome to restart on its own to where I was. What I don't want it is to ask me if I want to restore - why did I think it crashed in the first place? It doesn't do that in Windows/Mac. – Zlatko Sep 8 at 13:05
  • 1
    @Zlatko sorry I'm never using the restore functionality, I expect my chrome to start with a blank tab and no annoying warning, and this solution does that exactly. Why not give it a try and see if it works for your setup? Nothing to lose here … – panepeter Sep 8 at 13:48
  • Well I frequently do have several tabs open where I want them and starting blank would alter my workflow. I'll see how I can adjust, thanks for the help. – Zlatko Sep 9 at 14:04

protected by Community Dec 17 '18 at 12:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.