0

Trying to use HyperV for the first time. I have installed the 'feature' and rebooted. Now when I open Hyper-V and try to create a VM I go through the whole process and then it fails on "Hyper-V encountered an error while configuring the network on New Virtual Machine"

I tried to create the VSwitch manually in Hyper-V manager but that fails with "An error occurred while trying to retrieve a list of virtual switches, The operation on computer 'DESKTOP' failed: Generic failure"

I have checked my NIC settings and tried to uninstall the Hyper-V protocol, when trying to install it fails on "Could not add the requested feature. The error is: The requested operation was made in the context of a transaction that is no longer active"

I am on Win 10 Education 1709,

Thanks

  • During the New Virtual Machine Wizard, at the 'Configure Networking' section I have the drop down menu but the only option I have is 'Not Connected' – user3029356 Jul 27 '18 at 20:23
0

To able to create Hyper-V, we can try the following steps:

Step 1: we need to uninstall the third-part VMs if we have, including VirtualBox and any other VMs.

Step 2: reset the network: Open the command prompt as an administrator; Type "netsh winsock reset";

Step 3: restart the computer.

Step 4:, Open control panel, locate to control panel->Programs->Turn Windows features on or off->Hyper-V, tick the Hyper-V as below: enter image description here

In my environment, we can see "Hyper-V Management Tools" can be ticked by us, it means the features of this Hyper-V are not fully used if we does not tick it, so we need to tick it. But "Hyper-V Platform" is grayed out and it can not be ticked by us, it means the virtualization function is disabled, so we need to tick it. We can solve it like this: 1.Enter "BIOS" of the computer, enable virtualization function; 2.Find "Security" ,then find virtualization function, change "disabled" to "enabled".

Ensure tick "Hyper-V" including " Hyper-V Platform " and " Hyper-V Management Tools "

Step 5: try to recreate Hyper-V.

  • I have tried this, unfortunately it is still not working. It fails on the same error if I try to create the VM. If I try to create the network in Virtual Switch Manager it fails, "Generic failure". – user3029356 Jul 26 '18 at 17:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.