I've a VDSL/fibre connection to my home with about 5/30 Mbps up/down. I've discovered that uploading large files, my house's entire internet access is virtually non-responsive even to the extent my modem reports the internet connection is offline! enter image description here

Googling tells me this is quite common, effectively when the upstream is totally saturated my computer can't send response packets when downloading information, if I have this right.

But this seems crazy and surely there must be a solution? My model/router lets me set bandwidth limits overall and for IP ranges which seems a good place to start but I'm not sure how. First I just tried to set an upstream limit of "4Mbps" but this seems very kludgy, my upstream limit may vary all the time. Plus I'm not sure this wouldn't just saturate my network at the artificial limit in the same way.

enter image description here

I'm rather amazed my OS doesn't marshall traffic better (in the case only my computer is using the network and I can't browse the web while uploading). And also that even home-grade router/modems don't use some common sense to keep a bit of bandwidth aside for routine traffic. But then I know very little about this!

What, if any, is a good way to allow a device to upload/download near the limit to my house without crippling other devices' access? I'm not even after load balancing so two devices can download/upload at once, just that one device doing a big upload/download doesn't deny others a few Kbps for email and web browsing!

  • QoS implemented on the router
    – JW0914
    Aug 6, 2018 at 3:24

3 Answers 3


I've not got one of these (I've just looked at THIS emulator) but f you want your router to do Bandwidth control/QoS to fix this problem

Try something like logging in to the router, going to Advanced -> Bandwidth Control and enable. Set the total upstream and downstream bandwidth and save. Then you need to configure controlling rules.

The controlling rules will require some tweeking, but you want to add rules limiting the outgoing traffic from your computer (ie by its IP address) to something less then the actual thoughput you are getting on your connection - 80% of the result of a speedtest upload should be fine. You will also need to ensure the IP address of your device(s) are static - which you can do under Advanced->LAN Settings -> Address Reservation.

  • 2
    That “THIS” link is dead. Jul 28, 2018 at 14:49

Since you are using a TP-Link router you migth want to check out their FAQ section about bandwidth control: https://www.tp-link.com/uk/faq-557.html

In particular, I would focus on the minimum bandwidth feature. Quoting the FAQ article:

"From the rules, the max Bandwidth can ensure that PC1 and PC2 can take up all bandwidth when it’s alone to access the Internet and the min Bandwidth can ensure that they have the necessary bandwidth when more than one PC work at the same time."

You may want to reserve IP addresses if you are using DHCP to make things easier to configure single clients.

I think the best way to go is that, however if you don't wish to do so and / or your specific router model do not have the necessary features there are alternatives.

OS-level alternatives:

Windows You might want to check out this answer on Superuser: Way to limit bandwidth of programs on Windows?

Linux You might want to check out this answer on Superuser: https://unix.stackexchange.com/questions/34116/how-can-i-limit-the-bandwidth-used-by-a-process

To find the process to limit you can use the command: If you use Firefox:

ps -ef | grep firefox

luca 1448 1491 1 Jul23 ? 01:26:06 /usr/lib/firefox/firefox

luca 16471 32432 0 00:13 pts/10 00:00:00 grep --colour=auto firefox

luca 16509 1448 0 Jul23 ? 00:10:23 /usr/lib/firefox/firefox -contentproc -childID 11 -isForBrowser -prefsLen 20778 -schedulerPrefs 0001,2 -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 1448 true tab

In this case your PID would be 1448.


I had been on a ADSL line with 2Mbit download / 192kbit upload and for quite some time. The problem is that the outgoing ACK packets for incoming data get drowned in the upload. This will make the other side think packets got lost, and it will start resending packets, or assuming the connection is dead.

I solved this by having traffic control rules on my main computer (Linux), prioritising outgoing ACKs and small packets. Worked quite well. I'm not sure if similar rules on the router itself will work as well, because the buffers on the main computer will already be full and dropping packets.

I also don't know if and how this is possible under Windows.

If you are interested in the Linux setup, I can dig out from the old files if I search a bit.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .