0

I have Windows 10 1803 - I just installed KB4340917, this was happening before that - and that didn't fix it.

About 24 hours ago (I've changed nothing) my mouse started freezing for 0.5 seconds at a time. If I move it round in small circles it will happen between 1 and 20 cycles round.

This happens on my Microsoft sculpt ergonomic mouse, and both Logitech MX Master 2 and MX Anywhere 2S - both on Bluetooth and via their different dongles. I've tried different surfaces (though this desk has worked fine for months).

I've tried everything on this list - none work: https://www.makeuseof.com/tag/finally-fix-windows-10-mouse-issues/

I have a Nuc 8i7HVK with 3 4K monitors.

I've unplugged all USB drives from the computer - no effect.

I've tried putting scaling down to 100% on all monitors - no effect.

I've tried uninstalling all mice, and re-installing in device manager (rolling back isn't an option). Doesn't work.

I've rebooted, I've unplugged all dongles from my system and put them in individually. I've turned bluetooth off and on. I don't own a wired mouse but buying one is my next trouble shooting step.

Any idea how I fix this without reinstalling Windows (which is insane)? It's too infuriating to use in this state.

Thanks.

UPDATE

I've noticed 4K videos played on YouTube are pausing every 10-20 seconds with a similar cadence to the mouse pauses - so I'm concluding this isn't a mouse issue but a whole system freezing issue.

  • Probably graphics card driver, hard disk driver or USB controller (or all) driver update required... – Kinnectus Jul 27 '18 at 12:38
  • You could try using latencymon (resplendence.com/latencymon) to help diagnose the issue, it is designed to look for causes of stuttering – James P Jul 27 '18 at 12:47
  • If you have a USB extension cable, plug the receiver dongle into it and place the receiver as close to the mouse as possible, then see if the problem persists – Yorik Jul 27 '18 at 13:37
  • Turned out to be a graphics driver issue - thanks. – niico Jul 27 '18 at 19:29
  • I was instructed to completely uninstall and re-install both graphics drivers (on board intel and Intel radeon on hades canyon nuc), this fixed it – niico Mar 12 at 1:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.