0

since a week, i have a problem on my pc, the usb ports are not being recognized.

I've tried a lot of things (update drivers, uninstall the peripheral in the peripherals manager...) but none of them worked.

When looking in the peripherals manager, the "Controleur d'hôte compatible xHCI" (USB xHCI Compliant Host Controller) displays a yellow warning icon, and when clicking on it, it shows this:

image

Translated :

This peripheral can't start
{Operation failed}
The requested operation could not be completed

Also, the peripheral name has changed. The first time i tried to update the driver, it was "Intel® USB 3.0 eXtensible Host Controller" and now it is "Contrôleur d'hôte compatible xHCI USB" (USB xHCI Compliant Host Controller).

You can check my pc specs here and here.

0

You have probably installed the wrong driver. I suggest to :

  1. In Device manager, uninstall the device and reboot.
    This will let Windows install its own driver. If this doesn't work, continue on.

  2. Download and install the Intel driver from Support page of
    Intel® USB 3.0 eXtensible Host Controller Driver.

  • I already tried to uninstall the driver and reboot, but did not worked, and the drivers on the intel websites are not for windows 10, and it says that i do not have the minimal required configuration – Sawn Jul 29 '18 at 21:08
  • Seems like your chipset is too new for that driver. Your USB3 controller is the Sunrise Point-LP USB 3.0 xHCI Controller, although it seems like it has no driver of its own. You could go to the Asus download center and install the BIOS Version 313 from 2018/05/17 (but no others as they seem too old). – harrymc Jul 30 '18 at 6:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.