1

I have bought an ezbook 2 and installed Fedora 28. Unfortunately I have problems with the battery (INT33F4).

Specifically, I'm unable to charge my laptop with Fedora running. The charging light is blinking red, irrespective of wheter the AC charger is plugged in or not. I can only charge the battery with the computer fully off, and it behaves normally (red stable led when charging, no light when fully charged).

After reading some threads about it https://patchwork.kernel.org/patch/9687331/ https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895129 , it seemed that the support for it would be available in Kernel 4.18 (currently only in Fedora rawhide) so I upgraded my kernel and modprobed the drivers axp288_fuel_gauge and axp288_charger. After rebooting nothing new happened, and the battery still doesn't charge with Fedora booted.

I also tried to install tlp with no success (same situation as before).

Did someone experience the same situation? What can i do next to be able to charge my laptop while working with it? Thanks a lot.

I'm providing here the output of some commands when the battery should be charging (AC connected):

#  inxi -Fxz
System:    Host: idefix Kernel: 4.18.0-0.rc6.git2.1.fc29.x86_64 x86_64 bits: 64 compiler: gcc 
           v: 8.1.1 Console: N/A Distro: Fedora release 28 (Twenty Eight) 
Machine:   Type: Desktop System: Jumper product: EZbook v: N/A serial: N/A 
           Mobo: AMI model: Cherry Trail CR serial: N/A UEFI: American Megatrends v: 5.11 
           date: 11/29/2017 
Battery:   Device-1: axp288_fuel_gauge model: N/A charge: 82% status: Charging 
CPU:       Topology: Quad Core model: Intel Atom x5-Z8350 bits: 64 type: MCP arch: Airmont rev: 4 
           L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11520 
           Speed: 480 MHz min/max: 480/1920 MHz Core speeds (MHz): 1: 480 2: 480 3: 836 4: 948 
Graphics:  Card-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI 
           Configuration Registers 
           driver: i915 v: kernel bus ID: 00:02.0 
           Display: server: X.org 1.19.6 driver: i915 tty: 104x53 
           Message: Advanced graphics data unavailable for root. Old System? 
Audio:     Card-1: Intel HDMI/DP LPE Audio driver: HdmiLpeAudio message: bus/chip ids unavailable 
           Card-2: bytcr-rt5651 driver: bytcr-rt5651 message: bus/chip ids unavailable 
           Sound Server: ALSA v: k4.18.0-0.rc6.git2.1.fc29.x86_64 
Network:   Message: No PCI card data found. 
           IF-ID-1: wlan0 state: up mac: <filter> 
Drives:    Local Storage: total: 58.24 GiB used: 8.23 GiB (14.1%) 
           ID-1: /dev/mmcblk0 model: CJNB4R size: 58.24 GiB 
Partition: ID-1: / size: 57.04 GiB used: 8.03 GiB (14.1%) fs: btrfs dev: /dev/dm-0 
           ID-2: /boot size: 975.9 MiB used: 196.1 MiB (20.1%) fs: ext4 dev: /dev/mmcblk0p2 
           ID-3: /home size: 57.04 GiB used: 8.03 GiB (14.1%) fs: btrfs dev: /dev/dm-0 
Sensors:   System Temperatures: cpu: 58.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 307 Uptime: 38m Memory: 3.75 GiB used: 1.54 GiB (41.0%) Init: systemd 
           runlevel: 5 Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.17 
# lsmod | grep axp
axp288_fuel_gauge      20480  0
axp288_adc             16384  0
extcon_axp288          16384  0
industrialio           81920  2 axp288_adc,axp288_fuel_gauge
axp288_charger         20480  0
axp20x_pek             16384  0
roles                  16384  2 extcon_axp288,intel_xhci_usb_role_switch
# tlp-stat
--- TLP 1.1 --------------------------------------------

+++ Configured Settings: /etc/default/tlp
TLP_ENABLE=1
TLP_DEFAULT_MODE=BAT
TLP_PERSISTENT_DEFAULT=0
DISK_IDLE_SECS_ON_AC=0
DISK_IDLE_SECS_ON_BAT=2
MAX_LOST_WORK_SECS_ON_AC=15
MAX_LOST_WORK_SECS_ON_BAT=60
CPU_HWP_ON_AC=balance_performance
CPU_HWP_ON_BAT=power
SCHED_POWERSAVE_ON_AC=0
SCHED_POWERSAVE_ON_BAT=1
NMI_WATCHDOG=0
ENERGY_PERF_POLICY_ON_AC=performance
ENERGY_PERF_POLICY_ON_BAT=power
DISK_DEVICES="sda sdb"
DISK_APM_LEVEL_ON_AC="254 254"
DISK_APM_LEVEL_ON_BAT="128 128"
SATA_LINKPWR_ON_AC="med_power_with_dipm max_performance"
SATA_LINKPWR_ON_BAT="med_power_with_dipm max_performance"
AHCI_RUNTIME_PM_TIMEOUT=15
PCIE_ASPM_ON_AC=performance
PCIE_ASPM_ON_BAT=powersave
RADEON_POWER_PROFILE_ON_AC=high
RADEON_POWER_PROFILE_ON_BAT=low
RADEON_DPM_STATE_ON_AC=performance
RADEON_DPM_STATE_ON_BAT=battery
RADEON_DPM_PERF_LEVEL_ON_AC=auto
RADEON_DPM_PERF_LEVEL_ON_BAT=auto
WIFI_PWR_ON_AC=off
WIFI_PWR_ON_BAT=on
WOL_DISABLE=Y
SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=1
SOUND_POWER_SAVE_CONTROLLER=Y
BAY_POWEROFF_ON_AC=0
BAY_POWEROFF_ON_BAT=0
BAY_DEVICE="sr0"
RUNTIME_PM_ON_AC=on
RUNTIME_PM_ON_BAT=auto
USB_AUTOSUSPEND=1
USB_BLACKLIST_BTUSB=0
USB_BLACKLIST_PHONE=0
USB_BLACKLIST_PRINTER=1
USB_BLACKLIST_WWAN=1
RESTORE_DEVICE_STATE_ON_STARTUP=0

+++ System Info
System         = Jumper Default string EZbook
BIOS           = 5.11
Release        = "Fedora release 28 (Twenty Eight)"
Kernel         = 4.18.0-0.rc6.git2.1.fc29.x86_64 #1 SMP Thu Jul 26 14:28:43 UTC 2018 x86_64
/proc/cmdline  = BOOT_IMAGE=/vmlinuz-4.18.0-0.rc6.git2.1.fc29.x86_64 root=UUID=7c62df58-1e5d-46e7-8ea9-61ae0a7948f1 ro rootflags=subvol=root rd.luks.uuid=luks-7ebf8d83-0bb2-474a-8054-464040954efc quiet
Init system    = systemd 
Boot mode      = UEFI

+++ TLP Status
State          = enabled
Last run       = 13:58:55,      2 sec(s) ago
Mode           = battery
Power source   = battery

+++ Processor
CPU model      = Intel(R) Atom(TM) x5-Z8350  CPU @ 1.44GHz

/sys/devices/system/cpu/cpu0/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq  =   480000 [kHz]
/sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq  =  1920000 [kHz]

/sys/devices/system/cpu/cpu1/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu1/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu1/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu1/cpufreq/scaling_min_freq  =   480000 [kHz]
/sys/devices/system/cpu/cpu1/cpufreq/scaling_max_freq  =  1920000 [kHz]

/sys/devices/system/cpu/cpu2/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu2/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu2/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu2/cpufreq/scaling_min_freq  =   480000 [kHz]
/sys/devices/system/cpu/cpu2/cpufreq/scaling_max_freq  =  1920000 [kHz]

/sys/devices/system/cpu/cpu3/cpufreq/scaling_driver    = intel_pstate
/sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  = powersave
/sys/devices/system/cpu/cpu3/cpufreq/scaling_available_governors = performance powersave
/sys/devices/system/cpu/cpu3/cpufreq/scaling_min_freq  =   480000 [kHz]
/sys/devices/system/cpu/cpu3/cpufreq/scaling_max_freq  =  1920000 [kHz]

/sys/devices/system/cpu/intel_pstate/min_perf_pct      =  25 [%]
/sys/devices/system/cpu/intel_pstate/max_perf_pct      = 100 [%]
/sys/devices/system/cpu/intel_pstate/no_turbo          =   0
/sys/devices/system/cpu/intel_pstate/turbo_pct         =  32 [%]
/sys/devices/system/cpu/intel_pstate/num_pstates       =  19

x86_energy_perf_policy.cpu0                            = power 
x86_energy_perf_policy.cpu1                            = power 
x86_energy_perf_policy.cpu2                            = power 
x86_energy_perf_policy.cpu3                            = power 

/sys/module/workqueue/parameters/power_efficient       = N
/proc/sys/kernel/nmi_watchdog                          = 0

+++ Undervolting
PHC kernel not available.

+++ Temperatures
CPU temp               =    57 [°C]
Fan speed              = (not available)

+++ File System
/proc/sys/vm/laptop_mode               =     2
/proc/sys/vm/dirty_writeback_centisecs =  6000
/proc/sys/vm/dirty_expire_centisecs    =  6000
/proc/sys/vm/dirty_ratio               =    20
/proc/sys/vm/dirty_background_ratio    =    10

+++ Storage Devices

+++ AHCI Link Power Management (ALPM)
No AHCI-enabled host controller detected.

+++ PCIe Active State Power Management
/sys/module/pcie_aspm/parameters/policy = powersave

+++ Intel Graphics
/sys/module/i915/parameters/enable_dc        = -1 (use per-chip default)
/sys/module/i915/parameters/enable_fbc       =  0 (disabled)
/sys/module/i915/parameters/enable_psr       = -1 (use per-chip default)
/sys/module/i915/parameters/modeset          = -1 (use per-chip default)

+++ Wireless
bluetooth = none (no device)
wifi      = on
wwan      = none (no device)

wlan0(rtl8723bs)              : wifi, connected, power management = on

+++ Audio

+++ Runtime Power Management
Device blacklist = (not configured)
Driver blacklist = amdgpu nouveau nvidia radeon (default)

/sys/bus/pci/devices/0000:00:00.0/power/control = auto (0x060000, Host bridge, iosf_mbi_pci)
/sys/bus/pci/devices/0000:00:02.0/power/control = auto (0x030000, VGA compatible controller, i915)
/sys/bus/pci/devices/0000:00:03.0/power/control = auto (0x048000, Multimedia controller, no driver)
/sys/bus/pci/devices/0000:00:0b.0/power/control = auto (0x118000, Signal processing controller, proc_thermal)
/sys/bus/pci/devices/0000:00:14.0/power/control = auto (0x0c0330, USB controller, xhci_hcd)
/sys/bus/pci/devices/0000:00:1a.0/power/control = auto (0x108000, Encryption controller, mei_txe)
/sys/bus/pci/devices/0000:00:1c.0/power/control = auto (0x060400, PCI bridge, pcieport)
/sys/bus/pci/devices/0000:00:1f.0/power/control = auto (0x060100, ISA bridge, lpc_ich)
/sys/bus/pci/devices/0000:01:00.0/power/control = on   (0xff0000, Unassigned class [ff00], rtsx_pci)

+++ USB
Autosuspend         = enabled
Device whitelist    = (not configured)
Device blacklist    = (not configured)
Bluetooth blacklist = disabled
Phone blacklist     = disabled
WWAN blacklist      = enabled

Bus 002 Device 001 ID 1d6b:0003 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 3.0 root hub (hub)
Bus 001 Device 004 ID 1a40:0101 control = auto, autosuspend_delay_ms =     0 -- Terminus Technology Inc. Hub (hub)
Bus 001 Device 003 ID 6080:8060 control = on,   autosuspend_delay_ms =  2000 -- <unknown> (usbhid)
Bus 001 Device 002 ID 058f:5608 control = auto, autosuspend_delay_ms =  2000 -- Alcor Micro Corp.  (uvcvideo)
Bus 001 Device 001 ID 1d6b:0002 control = auto, autosuspend_delay_ms =     0 -- Linux Foundation 2.0 root hub (hub)

+++ Battery Status
/sys/class/power_supply/axp288_fuel_gauge/manufacturer      = (not available)
/sys/class/power_supply/axp288_fuel_gauge/model_name        = (not available)
/sys/class/power_supply/axp288_fuel_gauge/cycle_count       = (not supported)
/sys/class/power_supply/axp288_fuel_gauge/charge_full_design = (not available) 
/sys/class/power_supply/axp288_fuel_gauge/charge_full       = 10015824 [mAh]
/sys/class/power_supply/axp288_fuel_gauge/charge_now        = 8031296 [mAh]
/sys/class/power_supply/axp288_fuel_gauge/current_now       =      0 [mA]
/sys/class/power_supply/axp288_fuel_gauge/status            = Charging

Charge                                                      =   80.2 [%]

# acpi
Battery 0: Charging, 80%, charging at zero rate - will never fully charge.
# upower -i $(upower -e | grep -i battery)
  native-path:          axp288_fuel_gauge
  power supply:         yes
  updated:              dom 29 lug 2018 13:58:56 CEST (25 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    warning-level:       none
    energy:              34,9361 Wh
    energy-empty:        0 Wh
    energy-full:         43,5688 Wh
    energy-full-design:  0 Wh
    energy-rate:         5,13287 W
    voltage:             4,1 V
    time to empty:       6,8 hours
    percentage:          80%
    capacity:            100%
    technology:          lithium-ion
    icon-name:          'battery-full-symbolic'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.