0

My work laptop is a Thinkpad P50 and my personal laptop is a Thinkpad Yoga 14. To get linux onto my P50 without loosing VPN (which isn't supported on Linux at my work), I used CloneZilla to clone the P50 to the Yoga 14.

It worked great for several months. Then I stupidly pushed the Lenovo update app on the Yoga which wanted to do a BIOS upgrade and I stupidly agreed.

Now it won't boot at all. I hear a single beep and get a black screen. I disconnected the CMOS battery and flushed any remaining current, still the same issue.

This link says it might be an LCD issue, but I am very certain it's a BIOS issue so I am not ready to do what's on that list just yet.

After a quick search, I wasn't able to find a good tutorial on flashing a BIOS with a black screen.

I am not great at hardware, but as DIY projects, I use micro controllers like STM32's, and SOC's like raspberry pi's. So I am not averse to hardware work.

Does anyone how I can flash a BIOS onto a seemingly "bricked" laptop?

EDIT

There are signs of life now! On boot, the lights under the keyboard go on for a few seconds, and the Fn light stays on. I can hear/feel some humming and spinning.

I firstly disconnected the HD and added a monitor over HDMI, but same results. Plugged the HD back in now.

Looks it's not a BIOS problem, but some hardware problem. I reseated the RAM yet still no luck.

This is most likely an LCD issue. So how can I trouble shoot that further?

Also, without the DC adapter (i.e. on battery) the laptop goes dead.

  • Remove request for a tutorial as this is off-topic. – DavidPostill Jul 29 '18 at 15:50
  • 2
    Flash update tools should check the hardware - flashing a wrong BIOS with vendor tools is highly unusual. You could just have another hardware problem that manifested at this time (or prevented the flash update from running smoothly). – Turbo J Jul 29 '18 at 16:25
  • This is likely a BIOS setting... Try enabling "Legacy Boot" or disabling "Secure Boot" or similar options. Rapidly tap F1 while booting to access the BIOS setup. – acejavelin Jul 29 '18 at 17:00
  • @acejavelin looks you didn't read carefully! I am getting a black screen, so how can I see the BIOS settings? – Sam Hammamy Jul 29 '18 at 17:14
  • Like I said... Tap F1 repeatedly as soon as you hit the power, the default state is not to pause or show the logo or BIOS screen, just go to Windows 10 immediately via EFI boot. If that fails you will likely need to contact Lenovo for repair. – acejavelin Jul 29 '18 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.