1

Ever since it was introduced, I have loved the ability to prevent some of my apps from running in the background. I have used it to stop Edge from playing music when I lock my computer or just minimize Edge.

Microsoft first defaulted to disabled. Then they forced the setting on, probably because people had been complaining. Now, it's not even in the list. And the list is way shorter than it used to be.

How can I prevent Edge from running in the background? I would very much love to be able to pause everything it's doing by simply minimizing the window or locking the computer.

2

try to disable it by the register editor.

  1. run cmd.exe as administrator
  2. run regedit
  3. find the register path: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\BackgroundAccessApplications
  4. you can see key Microsoft.MicrosoftEdge_8wekyb3d8bbwe (or something like this)
  5. double click Microsoft.MicrosoftEdge_8wekyb3d8bbwe
  6. modify the Disabled to 1, if there is no such setting, just create it to disable it to be as background app.
    Name: Disabled
    Type: REG_DWORD
    Value Data: 1

If there is no Microsoft.MicrosoftEdge_8wekyb3d8bbwe in the BackgroundAccessApplications, create it by right-click the BackgroundAccessApplications and create new Key, they change the key name as Microsoft.MicrosoftEdge_8wekyb3d8bbwe.

In addition, if you also have the setting DisabledByUser, remember modify it as 1, too. If you don't have just modify the Disabled.

enter image description here

  • Oh my. That was crazy. I wonder how and why the BackgroundAccessApplications got cleaned out. The key wasn't there. After adding it as per your walkthrough, I can once again enjoy "minimize to pause" - and without restarting anything, too :) Thank you very much! – Heki Jul 31 '18 at 10:33
  • What's worse, after I rebooted my computer today, the key was gone. Do you have any ideas? I'm on a domain btw. – Heki Aug 1 '18 at 10:13
  • It sounds like the Domain configuration affects your PC, can you temporarily exit the domain, and reboot again to see if the register still disappears? Or did you get any message about this? Or just run gpresult /h C:\result.html to check the group policy from domain. – OOOO Aug 2 '18 at 3:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.