9

Let's say I have this H:\Films directory that I should like to have access to from my mobile (android) VLC player.

On Win 10, I created a local user, stream and created a password for it.

Then I went into the Network & Sharing Center and made sure that Turn on file and printer sharing was selected in both, private and guest or public (current profile) and that turn on password protected sharing was on in all networks (with an 128bit encryption).

Next I go to the H:\Films directory's properties and under advanced sharing select share this folder then in permissions, remove "Everyone" and instead add read access for the stream user only.

Alright, according to windows, this folder should now be accessible on \\MY_COMPUTER\Films.

I open up VLC on android and select the Local Network tab.

MY_COMPUTER shows up as an smb folder.

I click on it, expecting to be asked for credentials as is the case for other smb servers ... except I'm not being asked. There's just this circular loading icon spinning ad infinitum.

Tried with the windows firewall turned off, didn't make a difference.

Tried with full access to the folder for everyone, didn't make a difference.

How do I allow VLC to connect to this folder?

4
  • 1
    In Control Panel\All Control Panel Items\Network and Sharing Center\Advanced sharing settings in HomeGroup connections switch to Use user accounts instead of "Allow windows to manage...". Depending on version of your VLC you might want to switch to Enable file sharing for devices that use 40-56 bit encryptions. Your VLC also might not support SMB3 latest protocol in Win10, you might need to enable then in "Programs and features->Turn Windows feature..." old CIFS protocol, if you sure no one would try to exploit its vulnerability – Alex Jul 30 '18 at 18:27
  • @Alex there's no HomeGroup connections options in the advanced sharing settings of the Network and Sharing Center. Switching to 40-56bit encryption didn't do anything. – User1291 Jul 30 '18 at 18:55
  • @Alex old CIFS seems to have done the trick, giving me access, thank you. Want to make an answer out of it? – User1291 Jul 30 '18 at 19:05
  • Yeah, it's a good idea, may be some1 would need it too. – Alex Jul 30 '18 at 19:11
14

VLC probably doesn't support latest Windows SMB3 protocol. Go to:

Control Panel=>Programs and Features 

and click on the left pane "Turn windows features on or off" and check CIFS old protocol. Make sure that nobody would try to exploit its vulnerability.

3
  • 1
    i love you man.. spent 2 hours almost... until i saw the remedy... Bravo! – Moshiour Nov 28 '18 at 21:04
  • VLC devs could do better than requiring this 30 year old protocol to be enabled in order to make things work. Microsoft themselves urge people to disable it: blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1 – andromeda947 Jan 10 '19 at 2:46
  • 1
    @andromeda947 One of developer of VLC answered that they planing to support SMB2/3 in VLC ver.4.x – Alex Jan 25 '19 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.