0

On one server(my development desktop), I am able to execute kill command without sudo, but on the other one, I will got kill: kill 1 failed: operation not permitted.

I assume that kill command will execute /usr/bin/kill.

When I check the permission of the file on both server, it shows the same for permission part as lrwxrwxrwx 1 root root, which means that every user have read, write and execute permission of this file. Then why I need to do sudo on the other server? I am curious about which part between the two server makes this difference.

0

1 Answer 1

5

The error message kill: kill 1 failed: operation not permitted states that it comes from the kill command, not the shell which tried to execute it. Otherwise you would see a message like bash: /usr/bin/kill: Permission denied (which is headed by "bash").

Instead ask yourself which process you tried to kill, and who is the user running said process. You cannot kill other people's processes as a restricted user, and the kill command itself will tell you it is not allowed to do so...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .