0

Completed stock install of the java-based Minecraft server (version 1.13) on a Windows 10 machine #1. Forwarded ports, opened firewalls, and external "ping" sites confirm that they can see the server, and show the custom MOTD that I set up. So far so good. Port is 25565, and netstat -a -b -n confirms that only Minecraft is listening on this port.

On Windows 10 machine #2 (connected to the same network as machine #1 only via wifi) or Windows 10 machine #1 (hard-wired to network), I run Minecraft for Windows 10, log into Xbox Live, and "Add Server" using my WAN IP (not LAN IP). The server cannot be located, and if I try to connect, I get "Unable to connect to world" after a wait of about 15 seconds. How can I configure the server to allow these Win10 clients to connect? Extensive googling has been fruitless.

I also tried using "localhost" and "127.0.0.1" as the server IP in the Windows 10 clients, as well as the WAN IP.

I am out of trouble-shooting ideas, so would very much like some help - is this some kind of versioning issue? Or is there some kind of setting in server.properties that I need to change? Heeeeellpppp!!!!

EDIT:

  • No whitelisting
  • I tried the server LAN IP (192.168.x.x) as well - same error
  • The Minecraft client has no issues connecting to the "featured servers"
  • Router is Asus RT-N66U; no network services filters, blacklists, or parental controls
  • The clients are the UWP version, from the Microsoft Store, not the Java versions.
  • If you are on the same LAN as the server you should use the internal IP address of the computer running the server (usually something like 192.168.XX.XX). Many consumer routers do not properly handle routing traffic for your external IP back to the internal network. – heavyd Aug 1 '18 at 2:03
  • Any chance that you set up some sort of whitelist for the minecraft server? I'd say check the firewall but if you can get the MOTD from external sites im pretty sure that inbound connections to your server must be allowed. I don't think it's a local network (firewall) restriction since WAN doesn't work either, which it should. I've been owning a lot of routers in my live but never experienced the behaviour @heavyd was describing. Sounds to me like an issue with the minecraft server or its config itself. – confetti Aug 1 '18 at 2:34
  • Accessing the web server public IP from your private network will only work if your router supports NAT Reflection/NAT Loopback/NAT Hairpinning. Most consumer grade routers don't. – DavidPostill Aug 1 '18 at 7:53
  • Do you use Minecraft for Windows 10 or the Java version on your client? – Nordlys Jeger Aug 1 '18 at 20:42
  • Thanks for the replies, guys. Edited the original post to answer these questions. Still not working! :) – Adam Mac Aug 1 '18 at 20:46
0

You are trying to connect a client (programmed in C+, called "Bedrock Edition") to a Java Server. this will not function.

To use a Server with official Server Software use the Java version (like you did) and a Java Client.

Currently there is no official Server software for "Minecraft for Windows 10" except Realms. There is Open Source software available but it is not made/supported by Mojang or Microsoft. Reference

0

Thanks to @nordlys jeger. It looks like UWP Minecraft clients can't connect to Java servers. However, there are compatible (non-official) servers that can do the job, and also converters. See here: https://minecraft.gamepedia.com/Bedrock_Edition_server_software

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.