I insert the serial-USB convertor into my Mac.

and under the /dev I find the tty.wchusbserial1410.

but when I use screen to connect it:

screen /dev/tty.wchusbserial1410 9600

there get error:

Sorry, could not find a PTY.


Finally, I find the solution, there are a screen process not close normality.

So, in the Activity Monitor I closed it, then re-start the screen, it works.


I had a similar problem and I attempted a number of different solutions. Just wanted to share what made it work for me.


Tried to use the screen program to connect my lab PC to a Raspberry PI via the USB ports and an RS232 cable.

Ran the command screen /dev/ttyUSB0

Got the following error messages in quick succession.

"Cannot access line '/dev/ttyUSB0 for r/w: permission denied"

"Couldn't find a PTY"

Attempted solutions

  1. I tried to look in the activity monitor to see if there are any processes running, and there was none. So this was not the problem.

  2. Tried to change the /dev/ptmx file permissions

Ran the command ls -l /dev/ptmx

Output crw-rw-rw- 1 root root 5, 2 "datetime" /dev/ptmx

So it looked like the permission were already set. So this was not the problem either.

  1. Tried to mount /dev/pts by running

sudo mount devpts /dev/pts -t devpts -o mode=620

I got the message that the mounting was already done. Move on.

  1. Finally found this idea of adding to the dialout group looking at this post.


Ran the command - sudo usermod -a -G dialout $USER

Restarted the computer and voila, it worked. Was able to use screen program to make the connection.

Spend a few hours to figure this out. Hope this helps someone out. Peace.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.