17

I get this:

dialog box

Some people said use chmod to fix the execution files thing, but I still don't understand how to do it. Can some one tell me step by steps please?

  • Can you provide the path to the application? Where exactly on your filesystem is it? – Fanatique Aug 3 '18 at 6:43
  • I've seen this once in a while. A reboot will clear it in many cases. I haven't dug into the exact cause. – Hogstrom Aug 5 '18 at 2:11
  • @Fanatique it's in application section – seven tang Aug 7 '18 at 2:09
  • 2
    Using "The Unarchiver" to unzip the application worked for me (regular Archive Utility bundled with macOS Catalina did not -- see Dmitriy Pavlukhin's answer below!) – Jamon Holmgren Dec 19 '19 at 20:11
  • @JamonHolmgren the Unarchiver thing did the trick.. not even the zip command worked. – fguillen May 20 at 19:12
14

This happens because the application doesn't have execution permissions.

To make the application executable:

  1. Open a terminal window (CMD + Space -> terminal);
  2. Using the cd command, navigate to the place where the application is stored: cd <path_to_application>
  3. Run chmod +x <application_file> to make it executable. If it doesn't let you, sudo it:
    sudo chmod +x <application>.

The command from point 3 should look similar to this (thanks to @CJK):

chmod +x "/Applications/ShadowBat.app/Contents/MacOS/ShadowBat"
| improve this answer | |
  • 1
    Just to clarify by example for the OP, your command should look something like this: chmod +x "/Applications/ShadowBat.app/Contents/MacOS/ShadowBat", adding sudo at the start if needed. – CJK Aug 4 '18 at 11:46
  • Thank you @CJK. Not an OSX user, so didn't have an idea. Will add that to my post. – Fanatique Aug 5 '18 at 8:41
  • when I type: cd <path_to application>, it load: -bash: syntax error near unexpected token `newline'. what should I do? – seven tang Aug 6 '18 at 23:57
  • and when I type like: chmod +x "/Applications/ShadowBat.app/Contents/MacOS/ShadowBat" it load: No such file or directory. – seven tang Aug 7 '18 at 0:14
  • Not working anymore with MacOS 10.14 Mojave. – Grigory Nokhrin Jun 14 '19 at 19:40
13

In my case nothing helped until I accidently opened context menu on .zip file. Open With -> there were

1) Archive Utility (default) which always broke my app when unzipped

2) The Unarchiver, unzipped with this and application started

OS 10.14

| improve this answer | |
  • Can you describe your solution more accurately? I have been fighting this problem for 3 days :( On some MAC's, application runs without a problem on others (especially new ones) gets information as in the subject – user1100353 Oct 11 '19 at 12:30
  • @user1100353 just try another archive managing utilities. In my case standart Unarchiver which was installed in system helped. – Dmitriy Pavlukhin Oct 11 '19 at 15:24
  • unzipped with unzip command and it worked. – Harish Lalwani Nov 11 '19 at 11:13
  • This worked, thank you Dmitriy! – Jamon Holmgren Dec 19 '19 at 20:11
  • 2
    The Unarchiver works just fine. Thanks. – Lee Jun 20 at 16:43
4

@Fanatique is right, but be advised -

There are many possible causes for this problem, and most cannot be fixed using chmod. Handling program bundles with inappropriate tools often will "damage" executable bundles.

  • Making zip or tar archives with inappropriate settings will strip many file attributes;
  • copying via different file systems - e.g. a FAT32 formatted USB stick - might ruin file names (capitalization, special characters);
  • finally, copying applications between computers with the correct tools might result in invalid "receipt" files (sometimes commercial apps are cryptographically locked to certain hardware ids that way - the receipt will not be valid on the destination machine).

You shouldn't use chmod unless you have a good understanding of both file modes and ACLs, and more important, of what exactly the problem is, so you can fix it... this innocuous tool is well capable of recursively ruining your whole filesystem (and may even keep your system from booting).

If in doubt, I'd recommend deleting and reinstalling the pertaining app.

| improve this answer | |
  • I did and it didn't work – seven tang Aug 6 '18 at 23:50
  • I put it in the application section – seven tang Aug 8 '18 at 8:34
1

The following command typically solves most issues:

chmod +x "/Applications/ShadowBat.app/Contents/MacOS/ShadowBat"

but if it doesn't, there may be another application file within the application that you need to run the same command for. For example, right click the application and click "Show Package Contents" then look for a folder called "Versions".

There may be another application within this folder that you can follow the same process for the command above to make the application executable.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.