0

I have a CD-RW which I want to use as bootable CD. The problem is I cannot access it.

Tried firstly to format the disk. Just went on Nautilus, selected the CD and clicked on format. Does not work for any file system. The error message for FAT:

Error creating file system: Command-line 'mkfs.vfat -I -n "AA" "/dev/sr0"' exited with non-zero exit status 1:
stdout: 'mkfs.fat 4.1 (2017-01-24)
attribute "partition" not found
stderr: 'mkfs.vfat: unable to discover size of /dev/sr0
(udisks-error-quark, 0)

The window that pops up does not display the CD size and says the device is read-only.

Screenshot

I've read in some places that you have to mount the CD-RW before using it. So I tried

mount /dev/sr0 /mnt

but it raises another error:

mount: /mnt: can't read superblock on /dev/sr0.

A relevant fact is that the disk works fine in another machine (with Windows XP, not Linux). Is it possible that the culprit is the optical drive?

  • I'm confused... is the problem using CD-RW discs or using the drive itself? If you place a normal CD (like commercial software) in the drive, can you read the disc? And you don't use mkfs on RW optical drives, from the command line you would use cdrecord cyberciti.biz/faq/howto-linux-format-cdrw-dvdrw – acejavelin Aug 4 '18 at 13:03
  • It worked when I tried a commercial software CD-R, so I guess the problem is with CD-RW, although I do not have another one to test. I did try to follow the steps provided in that website, but I get 'Cannot open SCSI driver'! – Quasímodo Aug 4 '18 at 13:15
  • Yeah... sorry about that link, I didn't realize how old it was. Been years since I have bothered with RW material I will have to do some research, although Google might be your friend here. If I can find an answer before heading out for the day I will post it. – acejavelin Aug 4 '18 at 13:17
  • Is command line required, or is the GUI OK? What Linux distro and version are you using? – acejavelin Aug 4 '18 at 13:18
  • GUI is OK. I use Ubuntu 18.04. – Quasímodo Aug 4 '18 at 13:24
0

In Ubuntu, when using rewritable optical media, sometimes you need to format or "blank" the media before using it.

In the GUI, open Brasero and go to the Tools menu and select Blank, then select the disc/drive and continue. The disc will be blanked and you should be able to use the media after it completes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.