I have a problem that I'm hoping someone with more knowledge can shed some light on. I recently received a Razer Goliath 5.1 Soundbar for my birthday, capable of accepting input through Aux, Bluetooth, and Optical cable.

My motherboard is only capable of outputting stereo over SPDIF, so I bought a Sound Blaster Z sound card (which promises 5.1 over optical). Sadly, I've had only headaches and issues since I installed the damned thing.

I've managed to overcome most of the other problems that I've had with the card, however even as I type this out my sound has dropped out almost a dozen times - it simply stops playing through the speakers.

In the beginning I would restart my computer, and things would simply work again. More recently I've discovered that switching the encoder version in the Sound Blaster Z Control Panel to anything else, then back to Dolby Digital is enough to get my sound playing again.

enter image description here

I tried installing the newest drivers for both the card itself, as well as the Sound Blaster Audio Controller, and even newer/older versions of Sound Blaster Z Control Panel; nothing's worked, so I'm hoping you guys may have some insight.

I'm running Windows 10 Pro V. 1803, with all the latest updates; CPU: Intel i7-3770K; Motherboard: Asus Maximus V Gene

  • 1
    What happens if you use 'no encoder' & let the soundbar do it? – Tetsujin Aug 4 '18 at 18:30
  • @tetsujin - hi, when I disable Dolby Digital in the Sound Blaster Control Panel sound stops playing over the Speakers (Sound Blaster Z) audio device, and instead plays over SPDIF (Sound Blaster Z). Which is fine, except it only outputs 2 channels, not 5.1 (please see the NOTE in the screenshot on clarification on how the software routs sound with/without Dolby enabled). All sound tests through the Control Panel also stop outputting any sound ... – AndreiROM Aug 4 '18 at 18:42
  • OK, that probably reinforces what you said at the beginning of the question - your machine is incapable of outputting 5.1 at all, & is using a bit a a hack to push an undecoded signal to the soundblaster for those specific audio types. You may be hitting a processing bottleneck; the machine is just not capable of even pushing the undecoded signal as fast as required. Not sure there's a lot you can do to overcome that, but let's see if anyone knows better than me [many people do ;-)) – Tetsujin Aug 4 '18 at 19:18
  • @tetsujin - The whole point of this card is (supposedly) to enable me to play 5.1 over optical, which seems to work when Dolby is enabled. I would get it if a bottleneck would cause latency (which there was, but it was mostly resolved with newer drivers), but having the encoding fail altogether, then work again on toggle, seems to me like some sort of software failure. As you said, maybe someone has encountered this sort of issue before – AndreiROM Aug 4 '18 at 19:39

So I've sort of managed to solve the problem, and want to post this answer for the sake of anyone else encountering a similar issue. First of all, make sure to install the latest drivers, and version of Sound Blaster Z Control Panel.

When outputting over SPDIF (Sound Blaster Z), I selected "No Encoder" in Sound Blaster Z Control Panel, and enable the Dolby Digital setting on the speakers themselves (there's a button to toggle it on or off).

The sound coming out over the Leviathan seems to be 5.1, however it's difficult to tell because, duh, it's a soundbar, and all the speakers are right next to one another, and unfortunately the Sound Blaster Z Control Panel loses all ability to interact with the bar itself (I can't test the speaker output). It sounds good, however.

When I need to output over headphones I switch the output to headphones in the Sound Blaster Z Control Panel, and change the system sound output to Speakers (Sound Blaster Z).

With this setup I've had no drops, and no grief.

| improve this answer | |

I have the same card, I think some clarification on what it does is needed:

You need to use Dolby Digital Live! encoder and the 5.1 speaker setting (not SPDIF) for it to ENCODE 5.1 In REALTIME and send it over it's SPDIF. This is only required for games that have realtime surround sound, it takes the audio from the 5.1 channels from the game and encodes it in real-time to Dolby Digital 5.1 (hence the name Live). The receiver/soundbar getting this signal will see it as Dolby Digital 5.1. A Dolby Digital 5.1 encoded stream can be sent over SPDIF's 2 channel bandwidth, so this is a lossy encode, compared to sending the audio uncompressed, which SPDIF can only do 2 channels of, so you would need to use HDMI, but it seems like your soundbar doesn't have HDMI so have to use SPDIF.

You do not need to use the Dolby Digital Live! encoder for things like Movies or TV shows that have Dolby Digital 5.1, these audio streams are PRE-ENCODED and can be sent over the SPDIF as is, the receiver/soundbar will see these as Dolby Digital 5.1.

Going back to the sound cutting out problem, I just switched computers and am getting this issue too, not sure what it is, didnt happen on my old machine, but yes, switching the encoder to none and then back to Dolby Digital Live! fixes the issue. I will try the fix listed in this thread though.

But why do you need 5.1 for your soundbar, it doesn't actually have the rest of the speakers for surround? You could probably pass it 2 channel stereo and it would sound similar.

| improve this answer | |
  • Hi, did you ever figure out the audio drop issue? Thanks. – AndreiROM Jan 28 '19 at 13:40

I had the same issue for almost 18 months before I realized accidentally that updating my bios solved everything.

Over those 18 months I've tried replacing everything from the sound card to the cables, to the receiver and even the TV itself.

| improve this answer | |
  • This would have been better as a comment (you will be able to comment on other people's posts once you have a few reputation points). – Blackwood Nov 13 '18 at 2:16

Hello I have fixed the issue selecting in advanced features the "play stereo mix to digital output"

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.