5

My Homebrew version is:

Homebrew 1.7.1-114-g545eb91
Homebrew/homebrew-core (git revision 279277; last commit 2018-08-04)

When I run:

brew linkapps

The response I get is:

Error: Unknown command: linkapps`

And it's also not listed in brew commands. Is the command removed? Is there any replacement?

In my case I’m trying to use MacVim as default editor for some file types opened in Finder and sometimes MacVim isn’t listed in the open with menu in finder. So I am hoping to have a symlink in the /Applications/ folder which always points to the newest version of MacVim installed.

2 Answers 2

6

It seems like brew linkapps has been depreciated since around January 2017 according to this pull request’s comment thread. And the version of Homebrew you are using is up to date as off August 2018. So that explains that!

As for why it’s depreciated, as explained in that commit’s comment thread:

Unfortunately brew linkapps cannot behave nicely with e.g. Spotlight using either aliases or symlinks and Homebrew formulae do not build "proper" .app bundles that can be relocated. Instead, please consider using brew cask and migrate formulae using .apps to casks.

I am unsure if there is a generic solution in place to replace linkapps functionality—which basically created symlinks between the Homebrew “Cellar” and the /Applications/ directory—but this is most likely now handled on an app by app and case by case basis.

If you can provide more detail as to why you are looking to use brew linkapps—like what apps you are trying to use that might need it—then perhaps someone here can provide you with some more assistance.

1
  • Thanks for the explanation! In my case I'm trying to use macvim as default editor for some file types opened in finder, sometimes macvim isn't listed in the open with menu in finder, so I hope there's a symlink in the /Applications folder which always points to the newest version of macvim installed
    – tga
    Commented Aug 5, 2018 at 5:37
4

The alternative these days is brew install --cask macvim see here.
I tested it with MacVim just now and it works like a charm.

4
  • Welcome to SuperUser! How is your answer better than the already posted one? If you want to express that the given answer helped you please just vote. If you want to comment that it worked in a different way than the original answer intended, do so. Commented Jun 11, 2022 at 9:40
  • 1
    I just spent 30 minutes trying to figure this out. This answer actually answers the OP's question (albeit with the benefit of almost 4 years of technical advances)
    – Brandon
    Commented Jun 21, 2022 at 16:18
  • @DarkDiamond It just works 🤷‍♂️
    – Tobias
    Commented Mar 24, 2023 at 15:09
  • 1
    I had brew install macvim previously so it was required to first brew uninstall macvim Commented Apr 13, 2023 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .