1

On my main computer (Windows 10, 1803, 17134.165) no images or videos on Facebook or Instagram are displayed when using most browsers.

All of the images and videos (from both sites) are being served from a CDN - *.flhr2-2.fna.fbcdn.net

If I try to open an image directly I get the following errors:

  • Chrome (68.0.3440.84) & Opera (54.0.2952.64):

This site can’t provide a secure connection

instagram.flhr2-2.fna.fbcdn.net uses an unsupported protocol.

Unsupported protocol

The client and server don't support a common SSL protocol version or cipher suite.

  • Edge (42.17134.1.0) & IE (11.165.17134.0):

Cannot securely connect to this page

This might be because the site uses outdated or unsafe TLS security settings. If this keeps happening, try contacting the website’s owner.

Chrome includes an error code - ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Both sites work fine on Firefox (61.0.1).

Both sites work fine on other computers on my network - Windows 10 and Linux Mint 19, using the same versions of the same browsers.

So, it would appear to be something SSL related, on my main PC.

How can I fix this?

  • Chrome, IE and Edge use the same stack for TLS processing, while Firefox uses its own. Check Internet Explorer Settings' Advanced tab for SSL/TLS options. Compare them with the working other Windows 10 machines. – garethTheRed Aug 5 '18 at 10:10
  • Identical on working and non-working PCs – Shevek Aug 5 '18 at 10:33
1

What you can check :

  • The correct date & time is set
  • Enable all SSL/TLS Versions (a security risk). In Chrome this is in Settings > Advanced Settings > Open proxy settings > Advanced, scroll down to the Security section and check all SSL and TLS versions, click Apply, relaunch Chrome.
  • Clear all browsing data
  • Clear the SSL State. In Chrome this done in Settings > Advanced Settings > Open proxy settings, in Internet Properties, Content tab, click on Clear SSL State.
  • Disable the QUIC Protocol in chrome://flags/#enable-quic
  • Check if your antivirus blocks insecure SSL/TLS protocols
  • Delete your cache and cookies (Chrome link).
  • In Chrome use incognito mode. If this helps then temporarily disable your extensions to identify which one is causing the problem, in chrome://extensions.
  • Reset your browser settings.
  • Sorry for commenting on a random, inappropriate place, but have you read this post on Meta? – iBug Aug 5 '18 at 14:10
  • @iBug: I didn't, and there is good stuff in there. Thanks. – harrymc Aug 5 '18 at 14:19
  • So it looks like it was my AntiVirus - BitDefender has an option for Scan SSL. I switched it off and all is working again – Shevek Aug 5 '18 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.