0

Some time ago, a friend bought this ZEUSLAP laptop from AliExpress and she asked me to install Ubuntu alongside the original Windows 10.

Relevant specs: 240GB SSD + 1TB HDD (this turned out to be an SSHD)

Preparing for the Ubuntu installation I opened the firmware settings (UEFI) and noticed that of all the available SATA modes - "Native IDE", AHCI and RAID - the factory default was "Native IDE". Knowing that it should be AHCI because newer and better, I then first rebooted and installed some AHCI drivers in Windows, then changed the mode to AHCI. Then installed Ubuntu uneventfully in an SSD partition and it worked fine. Copied some video clips and music for my friend to the secondary drive and then played a few to test graphics performance and stuff like that and it worked like a charm [in Ubuntu].

But when I rebooted to Windows which is also installed in the 240GB SSD I noticed a weird problem: Playing the same media files already in the 1TB SSHD didn't work, it kept doing what looks like buffering so I suspected there was some problem reading from the SSHD, the same that was fine in Ubuntu.

What I did to troubleshoot:

  • Copied one big file to the SSHD resulting in acceptable speeds during the first seconds then dropping to almost zero, going up a little bit, down to almost zero again and so on.
  • Rebooted with Ubuntu and everything was fine as before.
  • At UEFI I changed the SATA node back to "native IDE" and then things seem to work in Windows (playing the video clips, copying to/from the SSHD).

So, my question(s) is/are:

  • Has anyone noticed any similar problem? Is there any solution to use the more modern AHCI without affecting Windows?

No need to tell me the laptop has a problem, that's evident and confirmed at the troubleshooting. Maybe it needs a UEFI update? I hope not because this Chinese brands rarely provide such kind of support.

  • 1
    Try to boot Windows into Safe mode, then into normal mode. – harrymc Aug 6 '18 at 17:16
  • Thanks for the suggestion. I already tried it but didn't post because I thought it wasn't relevant but perhaps I'm wrong? Anyway it made no difference whatsoever. And I can't test it again right know because she's traveling abroad with the problematic laptop (not so problematic with the factory settings as I mentioned in the post). – GabrielaGarcia Aug 6 '18 at 17:31
  • If the Native IDE method works, why would you want to go with the AHCI? Newer sometimes means not as well supported & tested. While AHCI might give some benefit in allowing extra queuing, unless you are heavily multitasking, you likely won't see much of a benefit. It might be a matter of finding an updated driver for Win7, I don't know, but unless you are sure you need features provided by AHCI, take the easier path. – Astara Dec 22 '18 at 15:41
0

I think you are missing some software that is required, meaning that not all the software required for AHCI was installed.

I suggest to turn on AHCI in the BIOS, then follow this article :
How to Do a Repair Install of Windows 10 with an In-place Upgrade.

The Repair Install will keep your installed applications and settings. However, just in case, take backups, which may include a disk image of the system disk.

  • Please remember the preinstalled Windows was in "Native IDE". Changing to AHCI resulted in an unbootable Windows. Back to IDE, installing the AHCI drivers and it booted normally, no complains, and file transfers within the SSD or between the SSD and an external drive were slightly faster. The problem was only with the secondary drive. I think this falsifies your missing software hypotheses, doesn't it? – GabrielaGarcia Aug 6 '18 at 17:49
  • Repair Install will put everything to the same version and may fix the problem, even if it's only a missing setting somewhere in the registry. It might be worth trying. – harrymc Aug 6 '18 at 17:57
  • Sorry, forgot to mention that I actually reinstalled Windows from the official ISO and tool, with AHCI, and activated it easily (it came with a genuine Windows :), not always the case with this shady brands). Also both SSD and SSHD use the same SATA bus, the SSD being a mSATA. Wouldn't both be affected if it was a software/OS problem? After all this I had strong suspicion of hardware/UEFI problems but... What sort of black magic Ubuntu has that made it work where Windows wouldn't? This is what I really don't understand. – GabrielaGarcia Aug 6 '18 at 18:08
  • You forgot to mention the most important part ... Answer : Windows and Ubuntu have different drivers, so it sometimes happens that a hardware problem that one OS stumbles upon is never detected by the other. So your AHCI controller might have a problem, or it's Windows that has a bug when handling that controller in that configuration. The possibilities are endless. You might as well stay in IDE mode if performance is not too bad. – harrymc Aug 6 '18 at 18:47
  • Yes, it works fine in IDE and from what I could gather while working on it, the performance is not too bad, slower but barely noticeable. And the user hasn't complained yet so I'll let her enjoy her summer vacations. Thanks a lot for your time. – GabrielaGarcia Aug 6 '18 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.