0

I have a Linux Mint XFCE system running on a lenovo z70. I've been trying to boot into the terminal on startup (but still allow me to start the graphical interface with startx if need be). Changing these settings here did nothing: http://ask.xmodulo.com/boot-into-command-line-ubuntu-debian.html and the directions here: https://community.linuxmint.com/tutorial/view/460 also do not work as there is no "quiet splash" line. I dont know if these are errors or what.

  • 1
    You didn't specified version on your LinuxMint. If it latest 18.x version, it use systemd, you need to use: systemd.unit=multi-user.target in place of text – Alex Aug 6 '18 at 18:12
  • Aha ty I did not know that. If you post that as an answer I’ll accept it! – Mark Deven Aug 6 '18 at 18:34
1

Linux Mint beginning with version 18 using different init system that calls systemd, so to be able to boot into console, one need to use:
systemd.unit=multi-user.target
Simply adding text to GRUB wouldn't work on such systems.

There a few methods you can use to boot into console by default:

Method 1:

edit file /etc/default/grub

Comment line GRUB_CMDLINE_LINUX_DEFAULT="" and add GRUB_CMDLINE_LINUX="text"

#GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX="text"

then apply changes by running: sudo update-grub

Now, tell operation system what systemd target to use on boot:
To boot by default in terminal, run:
sudo systemctl set-default multi-user.target

Next reboot will go to console without loading desktop.

To revert changes above (re-enable boot to GUI desktop by default) you need to run:
sudo systemctl set-default graphical.target

Method 2:

Disable MDM service:

To disable login to GUI desktop, you need to disable MDM (Desktop Manager) service:
sudo systemctl disable lightmdm

To revert changes, run:
sudo systemctl enable lightmdm

If you want to start GUI Desktop on demand without changing previous preference, you can run: sudo systemctl start lightmdm

  • I just realized I never accepted your answer. My apologies! – Mark Deven May 3 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.