I am running a server with arch linux and it is for all intents and purposes an nfs server atm. It is up and running and everything works wonderfully. I am able to connect from both my laptops (running arch, and ubuntu) so I will assume for now that I was able to configure everything properly. The issue comes when trying to connect from my windows 10 machine. I have enabled the nfs client and what not in the Turn on programs and features (Not sure if thats actually the name or not).

From the command prompt...

$ mount -o anon \\ipAddr/home/user A: 
A: is now successfully connected to \\ipAddr/home/user
The command completed successfully.
$ A:
Access is denied

And from the file explorer, it tells me I have insufficient permissions to access the drive, and I need to contact the network admin. Also running mount yields

$ mount
Local    Remote                                 Properties
A:       \\ipAddr\home\user                  Unavailable  

Does anyone have any ideas what my issue is?

  • have you tried mountvol.exe \\ipAddr/home/user/ A:? mountvol.exe /? might also help Aug 7, 2018 at 1:46
  • hmm this gives me the error The parameter is incorrect
    – j-money
    Aug 7, 2018 at 2:09
  • just tells me that mountvol.exe is a way to create list or delete volume mount points Creates, deletes, or lists a volume mount point... MOUNTVOL [drive:] path... (ommited for brevity)
    – j-money
    Aug 7, 2018 at 2:12

2 Answers 2


I decide to ditch windows' mount client and switch to sshfs as this is what I am used to and my preferred method of mounting and it worked like a charm!

  • Start regedit
  • Locate HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ClientForNFS\CurrentVersion\Default
  • Add two DWORD values: AnonymousUid, AnonymousGid

  • enter "1000" decimal base. regedit values

  • restart NFS service or reboot pc.

  • Open Computer and Click the Map netwok drive button on the toolbar.

  • Enter HostIP:/share on the Folder text box.

  • Click Finish.

If you encounter an error;

  • Enter HostIP/share on the Folder text box.

  • Click Finish.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.