0

I have a raspberry pi connected over wifi to my LAN. The LAN network on the router is a bridge of wifi and wired ethernet. When I ping raspberry from my PC connected to itself through wired LAN, everything is fine. But when I try to connect from my smartphone connected on the same wifi as the raspberry, first connection(ping) fails. When I try a few minutes later then it works for a while.

Has anyone an idea where the problem may be?

  • I'm not sure if its related, but I have a server that has two connections going to it, 10. and 172. They are two seperate networks, and I found that when both are enabled and set up to "automatically" connect they interfere with each others operations. I'm not sure if this could be happening in your case as well. In order to avoid this issue I usually disable the private network(172) and only use it when I need it, and then disable it when I'm done. – RickwhoPrograms Aug 7 '18 at 20:46
0

I believe this may be an issue where your phone is connected to two networks at the same time - one for your WiFi network, and one for the cellular data network. When the phone tries to ping your Raspberry Pi, it sometimes tries to ping it over the cellular network, where LAN P2P connections are disabled and therefore fails the ping. However, it sometimes defaults to the WiFi network, which has LAN connections enabled and therefore can see and ping your Pi server.

Please try disabling all cellular connections on your phone and see if the ping succeeds 100% of the time then.

Also, if at all possible, try pinging your Pi from another computer connected to WiFi, such as a laptop, and see if the connection is intermittent then. If it is, the problem may be elsewhere.

  • So this may be in fact a possible cause. But it's definitively not in my case as - I can ping without any problems all other hosts from my smartphone in same lan subnet, as long a they are connected with a wire - I also observe same problemativ behaviour from my laptop when it has only a wireless connection to lan – lweller Aug 8 '18 at 6:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.