0

Recently I reinstalled windows 10 on my Asus K46CB from scratch and for some reason, every time i put it to sleep it turns itself off after a few hours. It just happens if i leave it sleeping without the AC adapter but i don't think it has nothing to do with the battery since it is almost full whenever i turn it on again and still usable for at least 1 hour. Also: it never happens when it is turned on, but it ALWAYS happen after a few hours sleeping.

I checked events log but there is any clue there whatsoever. There's not even a log on "Windows Events > System" about turning off.

It also does not show any message after this, or do any event like a Chkdsk. The startup is regular as it always is.

It might be worthing noting that i'm using a 250gb SSD as C drive (to store windows, programs and ubuntu) and a caddy with HDD on the optical drive. I've been using this for over 2 years and never had this kind of problem before.

Also, i got a dual-boot with ubuntu on this PC (booting via GRUB). I can't tell wether this issue appeared after installing ubuntu or after reinstalling windows since they were both done at the same time.

Any help? Thanks

EDIT: I just realized that there are critical events saying that "The system has been restarted wihtout proper shutdown. This issue might be caused due to sudden lack of energy, when the system stops answering or freezes." (Kernel power-event 41). I have translated it so it might be a little bit different than the original message shown in english versions of windows.

SOLUITON:By going to the area otto wang suggested below, you can find inside the "Sleep" option the field "hibernate after". In my case, it was set to 120 minutes, leading the PC to crash after this time while sleeping. Just deactivated it and it stopped happening. Hope it works for whoever have this problem as well

0

Try the following solution, hope it can help you.
1. Open Settings in Start
2. Click Power & Sleep
3. Click Additional Power Options
4. Then click Choose when to turn off the display
5. Click Change advanced power settings
6. In Power Options, click Change settings that are currently unavailable
7. Find Power button and lid, expand it
8. In the Setting, choose Do nothing instead of Shut down

  • Yeah i tried to do that before but is was already chosen to do nothing. But I realized that the computer was set to hibernate in 120 minutes on the battery. It usually turned off around 2~3h after sleeping, so i guess it might be this (specially because this doesn't happen when i'm with the AC). I will check and update the thread if it is the case – Jn Coe Aug 8 '18 at 13:05
  • If this, just set the time longer or disable it, you can use powercfg h off, to see if it helps. – OOOO Aug 9 '18 at 1:41
  • Yeap, that was pretty much it. Just let the computer sleeping the whole night and it was still sleeping by the day. Thank you for bringing me the suggestion that gave me this insight – Jn Coe Aug 9 '18 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.