0

While trying to use RUFUS to install an UBUNTO ISO to my flash, and after 20 minutes, Rufus crashed. And now my USB is not detectable by windows 10, or any other device I put it in. I have tried looking at the device manager, but it doesn't show there even with an un-allocated drive letter. I have tried disk manager, DISKPART, and partition magic to try recover my USB with no luck, none of them read the USB.

2
  • 4
    It may be "RUFUS failed to copy ISO after USB went unresponsive". Aug 9 '18 at 10:32
  • Brand new USB down the drain. YAY!
    – Azraelz
    Aug 10 '18 at 3:32
2

From what you are describing it was the failed USB that made RUFUS crash. Not vice-versa. RUFUS and similar tools cannot physically damage USB. At the very worst they could wipe it clear, and possible even remove the partition table.

If device is not detected by Windows device manager and disk manager and is also not detected by other OS and on other machines you can be pretty sure USB is dead.

Unfortunately now you have a damaged (useless) USB in your hands. Give it up and purchase another one - you will save yoruself some time. Also consider purchasing a USB of widely known vendor at a decent price to avoid disappointments in future. Cheap unbranded USB drives from ebay fail way too often to put any trust in them.

3
  • This was a brand new USB of a well known vendor (ScanDisk) Hence why I doubt it was the USB that caused the problem.
    – Azraelz
    Aug 10 '18 at 3:31
  • Are you sure it was ScanDisk? Then it definitely was a cheap fake. Real brand is called SanDisk Aug 10 '18 at 6:56
  • lol, yes, SanDisk, my phone love to auto correct everything I type.
    – Azraelz
    Aug 10 '18 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.