10

I was hit by some hardcore power-tripping forum mods on the Arch Linux forum, so here I am.

I'm trying to run GUI apps on WSL, such as dolphin or kate. However, none of them can find libQt5Core.so.5, despite it being installed in /usr/lib as you'd expect. Here's a terminal transcript:

/u/lib » DISPLAY=:0.0 dolphin
dolphin: error while loading shared libraries: libQt5Core.so.5: cannot open shared object file: No such file or directory
/u/lib » pwd
/usr/lib
/u/lib » ls -la | grep Qt5Core
-rw-r--r-- 1 root root     1143 Aug  7 06:05 libQt5Core.prl
lrwxrwxrwx 1 root root       20 Aug  7 06:05 libQt5Core.so -> libQt5Core.so.5.11.1*
lrwxrwxrwx 1 root root       20 Aug  7 06:05 libQt5Core.so.5 -> libQt5Core.so.5.11.1*
lrwxrwxrwx 1 root root       20 Aug  7 06:05 libQt5Core.so.5.11 -> libQt5Core.so.5.11.1*
-rwxr-xr-x 1 root root  5234312 Aug  7 06:05 libQt5Core.so.5.11.1*
/u/lib » ldd `which dolphin`
        linux-vdso.so.1 (0x00007fffdb426000)
...
        libQt5Core.so.5 => not found
/u/lib » pacman -Qk qt5-base
qt5-base: 3546 total files, 0 missing files

Note that other GUI apps work fine - anything compiled against GTK, including Firefox, work perfectly. I just have to set the $DISPLAY variable. Not setting the var doesn't help, as you'd expect.

Any ideas? Thanks!

  • 1
    You were NOT hit by power-tripping on the Arch forums. I saw your post there, your post was dust-binned because Arch on WSL is NOT the official Arch. If they allowed every kind of derivative of Arch then the forum and Wiki would be useless because of all the special instructions for each flavor. If you want official support on the Arch forums then run ARCH. Period. – headkase Aug 10 '18 at 0:00
  • I was just hoping for some community help with diagnosing my issue, and ruling out non-kernel issues. It's not like I was calling the support line of a commercial product which I was using against the TOS or something. – Ripdog Aug 10 '18 at 0:31
26

Found a fix: https://github.com/kdudka/csmock/commit/96a4a759a7de39f8da109202f4fa14c76a0ae68f

Or simply run:

sudo strip --remove-section=.note.ABI-tag /usr/lib64/libQt5Core.so.5

The root cause does seem to be related to the lack of renameat2() in the WSL 'kernel'.

More information: https://github.com/Microsoft/WSL/issues/3023

Thanks to Daniel B for the nudge to get me started on this!

| improve this answer | |
  • 6
    For some reason, my QT libraries were in a different location, so I needed to run: sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/libQt5Core.so.5 – bart Sep 4 '19 at 18:46
  • @bart The reason must be that you are not running Arch Linux. Probably Debian or Ubuntu. – ypnos Jan 20 at 14:30
  • @ypnos you're right, that'll be the reason. Nonetheless, this answer solved the problem on Debian as well - with the path modification. – bart Jan 22 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.