0

I am having a problem with my Laptop booting into Windows.
TL;DR: The BIOS doesn't detect any connected devices as bootable, and the boot device options list contains entries that are not connected.

Long story:
I wanted to reinstall Windows 10 from scratch (it started getting laggy) and convert the disk to GPT in the process.
- I booted the installer USB in UEFI mode, erased the whole disk, converted to GPT, and installed Windows.
- The problem is that it didn't boot, but instead showed the "No bootable devices, press any key to refresh" message.
- I tried installing Ubuntu 18, but it gave a "General Input/Output error"when it came to the GRUB installation stage, and it also couldn't boot.
- I reinstalled Windows 10 and pressed F9 (change boot device) while booting to manually select the hard disk and I see that the options list still shows the 2 bootable USBs I had previously booted from, but are not currently connected.
- I removed the CMOS battery and the laptop battery for about 24 hours.
- All BIOS settings were reset except for this list.
- The only way I can boot Windows is by stopping boot (F9) and choosing Boot From EFI File > Microsoft > Boot > bootx64.efi (or something similar).
Lastly, I tried updating the BIOS once I booted into Windows using the utility provided by HP, but the installer fails about 25% in.

What should I do to return my BIOS to normal behaviour?

Edit - added screenshots:

The "No bootable device" error
Boot options menu. Here you can see 2 devices (Toshiba USB and Seagate HDD) that I used to boot from previously, but are not currently connected. Newly connected devices are not listed.

Edit 2: It is also worth noting that the laptop can't go into sleep or hibernate modes. It can sleep, but if I try to open it again it will crash (the same way as if you held the power button for 8 seconds). And if I choose hibernate, the screen would go blank for a few seconds and then get back to the log in screen as if I just locked it.

Device: HP pavilion-15 p214ne
BIOS: Insyde F.36 (2/2/2015)

0

Method 1

  • UEFI = On

  • Secure Boot = Off

  • Legacy Options = Enabled

  • Boot Priority = Windows Boot Manager (EFI/GPT/Whatever it says)

But NOT Windows Boot Manager on Seagate UUID-Hopefullyyoudonthaveaseagate [Disk Name]

Method 2

Bootrepair disk.

  • The first option isn't present (it is the default). The second can't be changed (and is Off). The 3rd is on. And boot priority didn't help at all. – Abounegm Aug 10 '18 at 22:55
  • I already tried the 2nd method. It didn't work. I think it fixes boot problems related to files on the HDD, not the BIOS. I believe my problem is in the BIOS. Anyways, here is the link to its repair info: paste.ubuntu.com/p/4wDpzFbH3w – Abounegm Aug 12 '18 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.