I migrated from Mint 17.3 MATE to Mint 19 MATE and my Ctrl+Alt+Shift keyboard shortcuts stopped working.

If I try to enter a Ctrl+Alt+Shift shortcut in mate-keybinding-properties, the Alt doesn't register

For example: If I press Ctrl+Alt+Shift+X, it registers as Ctrl+Shift+X.

Is there a way to fix it?


This is an Xorg bug and as I understand it manifests itself by Xorg giving preference to shorter shortcuts before more complex ones that include the same keys as a subset.

There is a patch in the Freedesktop bugzilla ticket and you can install it using the commands below (documented already in this Cinnamon issue on Github):

sudo add-apt-repository ppa:nrbrtx/xorg-hotkeys
sudo apt update
sudo apt dist-upgrade

It is an old bug (check the bugtracker here), and there is a patch:

sudo add-apt-repository ppa:ubuntu-wine/ppa
sudo apt-get update

# install the patch from ppa
sudo apt-get dist-upgrade


As I understood, Linux Mint starting from the version 19 uses the updated version of the XOrg-system, which uses the keypress event instead of the old good keyrelease, and now the shortest shortcuts hide the longer ones. This behavior is encouraged by XOrg itself.

The installed patch changes the settings of the XOrg (though, I'm not sure about the last statement).

  • 1
    Mint v19 Tara x86_64, add-apt-repository ppa:ubuntu-wine/ppa fails with HTTP Error 404: Not Found, then Cannot add PPA: ''This PPA does not support bionic''.. – agc Dec 2 '18 at 10:32
  • You are right. I have checked in Ubuntu 16.04 vs 18.04. On 16.04 layout is changing while I was releasing Left shift or Alt. I'm trying to find hot to change behavior for 18.04 – UNIm95 Aug 4 '19 at 15:32

I started over from scratch (no problem there) and migrated only some of my select settings and everything worked all right.

Then the problem resurfaced when I added a different keyboard layout and set Alt+Shift as the key combo to switch layouts.

It looks like in Mint 19, unlike in Mint 17.3 (I imagine the underlying Ubuntus will probably be affected too), there's some kind of a conflict between the two settings.

I "solved" the problem by setting Both Alts as my layout switching combo, but I would call the conflict a bug.

grep "_alt_" /usr/share/X11/xkb/rules/xorg

to view all binding with alt or ctrl altshiftx You can even modify it at your preference.

  • Thanks. It's only getting me ` altwin:ctrl_alt_win = +altwin(ctrl_alt_win) altwin:swap_alt_win = +altwin(swap_alt_win) grp:ctrl_alt_toggle = +group(ctrl_alt_toggle) grp:ctrl_alt_toggle_bidir = +group(ctrl_alt_toggle_bidir) terminate:ctrl_alt_bksp = +terminate(ctrl_alt_bksp) `. No conflict with the keybindings I'm trying to setup (/carry over from my old system). – PSkocik Aug 11 '18 at 11:24
  • It looks like I might be affected by this bug github.com/mate-desktop/mate-control-center/issues/132 – PSkocik Aug 11 '18 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.