2

takes a deep breath My System: Windows 10 Home Version 1703 OS build 15063.966 Trying to update to version 1803 (KB4340917)

The updates continually failed. I literally had the windows 10 upgrade assistant annoying me every time I used my PC. It would automatically try to update and fail during the restart every time. Eventually I went to fix it... the following was the nightmare to the resolution.

Put the computer into safe mode and tried removing recent windows updates. Restart and PC won’t boot. Use WIndows Recovery Environment (WRE) from a genuine DVD. Try the startup repair, fails. I forget the error. Also just to add, trying a refresh or reset throws a device is locked message from the WRE. Try command prompt. Run: bootrec /fixmbr - works bootrec /fixboot - works bootrec /rebuildbcd - fails Error is “The requested system device cannot be found” When searching this error forums/others say this is because of USB WRE. Not my issue. Try using Diskpart to set active partition, try to move boot files.. always fails. Try to from System file checker (sfc) running "sfc /scannow" Error :There is a system repair pending which requires a reboot to complete. A reboot does not resolve this. Tried dism.exe /image:C:\ /cleanup-image /revertpendingactions I forget the error but something along the lines of disk not available. However when trying to write new directories to the disk in command prompt, I am able to do so. As well as confirm through Diskpart that the drive isn’t read only. I’ve left out a ton of other troubleshooting and commands as I’m writing this after the incident and can’t remember all the commands and errors I recieved, I wish I could to help others more.

Eventually the solution was to remove the drive from my PC, connect it to a friends PC and execute the following commands.

Reformatted the NTFS system reserved 100mb boot partition. This might have been the whole issue as it appeared to be full but only using 26 MB... ?!? But shown as full in disk management. Ran bcdboot.exe {driveletter}:\windows /s {e}: where driveletter is you main partition with windows files/programs/all your data and where e: is the system reserved boot partition. Also the { } are not included in the actual command.

My questions is this:

Why wasn’t I able to execute the commands within WRE using the genuine Win 10 MS DVD connected to my mobo/PC? Some type of bios issue?

3

yes, could be bios issue, you should have tried to check / even now check and make sure your bios is up to date to prevent any further issues

  • 1
    I did go and grab the latest drivers. Asus Maximus hero VII btw. Good idea though. – Douglas Karr Walston Aug 11 '18 at 22:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.