0

I am struggling with my Thinkpad dual boot setup and fixing one problem might have led to another. I am a complete noob and not sure which piece of info would be relevant to the problem, so I will briefly summarize what I did to the laptop here.

Background: The laptop had a Win10-Ubuntu14.04 dual boot setup. It started showing an SSD detection error randomly during boot since last month, so I made an image of the whole disk using Clonezilla and sent it in for a repair. When I received my laptop back from the repair depot, the motherboard was replaced but the SSD is still the old one. The partitions remained the same but the content in the two partitions that had been created for Ubuntu were erased. My Windows installation seems to have been reset, with some of my custom settings and personal files intact.

I want to install Ubuntu back onto that empty space on my SSD, but Ubuntu installer somehow did not recognize Windows as an existing OS (it did not show an option to install Ubuntu alongside Windows). The installer detected all the GPT partitions correctly, but Gparted did not.

I tried instead to restore my whole dual boot setup from my Clonezilla image. Clonezilla verified the image and showed all partitions inside the image correctly. In the process of restoration, though, it complained about not recognizing certain partition on my SSD and aborted. Since Clonezilla had already begun restoration, I could no longer boot into anything. I then used Win10 installation stick to wipe all partitions and install Windows 10 afresh, which worked perfectly without any sign of software or hardware issue. Now I made a second attempt to restore my Clonezilla image. This time Clonezilla did not complain and I restored the image successfully. I even got the correct boot screen showing the options to either boot into Ubuntu or Windows. I selected Windows and everything seemed good. (Up until this point, the UEFI settings has been working perfectly, allowing me to change boot order every time without problem. Due to the difficulties with partitions, I was playing with the UEFI/Legacy/CSM options a lot too; though, there did not seem to be a problem with this setting so far.) However, from within Windows, when I checked the partitions, it showed that the two Ubuntu partitions were empty. Windows did some auto updates and when I shutdown/restarted, the dual-boot grub screen no longer appeared--it just booted directly into Windows since the second boot onward.

Plugging in the Clonezilla stick to try to restore the image again, it did not boot into the stick. So, I entered the UEFI/BIOS menu, meaning to change the boot order once again. Here is where I don't understand:

Under "Startup" tab >> "Boot", if I press enter when "Boot" is highlighted, the whole thing freezes at that screen (with all the tabs other than "Startup" disappear--picture here. It does not enter the screen that's suppose to list all the drives). The "Item Specific Help" info on the right hand panel never shows up for "Boot" as it does for the other options (not sure if this's normal). I can still navigate or change any other UEFI settings without problem as long as I don't touch the "Boot" option. I held the power button to power off, remove all USB devices, entered the UEFI settings again, and it still froze at the same place.

Having no other choices, I booted into Windows and played with its recovery menu. To my surprise, I found that Windows 10's recovery tool has an interface to set a reboot from a specific drive. The recovery menu also listed all my drives correctly. So, I used this tool instead of UEFI interface to reboot to my Windows 10 USB installation stick. I wiped out all partitions and did a fresh Windows install, which goes perfectly. Currently, my laptop works normally with only Windows 10, single-boot, but the UEFI menu still hangs the same way every time I try to enter "boot order" menu. My goal here is to fix UEFI menu from hanging and then do a fresh installation of Ubuntu alongside Windows. Without understanding what is wrong with my laptop, I fear of making further changes on it.

Additional info: I did not touch any other UEFI settings except 1) Boot order 2) UEFI/Legacy/CSM 3) Secured boot and fast boot: disabled long time ago.

Questions:

  • What could possibly cause UEFI menu to freeze at the "Boot" order options? Does this sound like a software of hardware problem? (I have just replaced the motherboard, so hopefully it's not the motherboard again.. :() If software, could Clonezilla image restoration or Windows 10 mess up with the UEFI? Or maybe it is caused by me changing between UEFI/Legacy/CSM settings? Or could the messed up SSD partitions confuse UEFI boot order utility? (Though, it did not confuse Windows 10's recovery utility.)

  • What should I do to diagnose or fix this? Since I am a noob and this is dealing with motherboard, less risky tricks are preferred, if possible. Or I could take it to a repair shop for help.

  • When the UEFI menu freezes, what is the best thing to do? Is holding power button the best thing to do in my scenario?

Thanks so much for reading! I am at my wit's end. Any help is highly appreciated!

0

I've have had 5 operating systems running on a 486/33 DX - DOS 5.0, Free BSD, OS/2 warp, Windows 3.1 and Windows '95, many years ago. Not exactly a small feat since generally you can only have 2 primary partitions per HDD. So you have an issue selecting the boot partition via UEFI and it causes a system lockup? Question: Does GRUB load or just your version of Windows without a hitch without hitting F2 or F5, or whatever gets you into the boot menu? If it does, I am prone to think you have an issue with the UEFI was is directly related to the BIOS. You were very verbose with the issues at hand, and at this time since the mobo had an issue do you have another system you can test these installations on - via Clonezilla or from scratch? To me, it sounds like a hardware issue. You did not mention the BIOS firmware (Award, Phoenix, AMD, or something else?) This is risky, but if Windows (x) boots have you tried the manufacturer and do a firmware update if available? This is risky, as a power outage can corrupt the BIOS chip and this measure is not to be done lightly. It can render your system useless - please heed these words. I've done many a BIOS update that fixes a lot of problems, but it has always been done with a battery backup of significant run time and responds within nanoseconds should power be lost.

Personally, I think it's a mobo issue but you have to start somewhere. Just have a backup system just in case?

Much luck!

  • Thanks for responding. After Clonezilla restore, grub screen appeared only at the 1st time it booted up. From the second boot onward, the grub screen never appeared again and it booted immediately into Windows. I then did a fresh install of Windows, wiping all partitions altogether. So, currently it's no longer a dual-boot setup, and just boots into Windows without grub screen. Still, same UEFI freezing behavior persists since. (I now update the post to clarify this.) – Vicon Aug 12 '18 at 8:19
  • BIOS Version/Date: LENOVO N1NET41W (1.28 ), 5/23/2018; BIOS Mode: UEFI. There is a BIOS update (1.29) available 25 Jul. I'm actually confused why Lenovo repair depot didn't update BIOS to that newest version when they replaced the mobo and updated BIOS for me, so I was kinda reluctant to update it myself. – Vicon Aug 12 '18 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.