Recently I updated my router's firmware to DD-WRT. None of my devices have problems with this update. None of the other MacBooks, none of the Windows laptops, none of the phones have issues.

Only my 2016 15" MacBook suddenly has connection issues, since the DD-WRT update. This laptop has no issues on any other WiFi networks. I tested this with at least 6 other networks.

What happens during connection issues:

  • Wifi stays connected
  • Can't ping to any IP outside of the first router's network.
  • I live in the middle of no-where, with maybe one other wifi network around.

Where do I start searching for this issue? I searched the log files on the router, and the log files on the laptop, but I did not find anything suspicious.

This is the wifi.log.

  • Please update the question with DD-WRT version and hardware make/model. It's weird that only one of the Macs is having trouble. I'd suggest clearing the known Wifi networks out of the problem Mac, turning the adapter off/on from the system tray, and trying to connect again. – Christopher Hostage Aug 12 at 14:20
  • @ChristopherHostage DDWRT build 36410. Router model is TP-Link Archer C5v1. Turning the wifi off and on fixes the problem right away, but it keeps happening every few minutes. When the problem occurs I can still ping to internal addresses, but not to external addresses. – Joel'-' Aug 13 at 7:56
up vote 0 down vote accepted

Option-Click the Network icon then select Open Wireless Diagnostics.

Select Window->Info from the menu or type Option-Cmd-2. This will provide you with better insight into the parameters your Mac sees on the wireless environment in your location.

  • Thanks! I was indeed looking for something like this. Interestingly enough it says: Cannel Width: 20Mhz, whereas the router says Channel Width 40MHz. – Joel'-' Aug 13 at 8:04
  • Glad to help, if this answered your question please mark as such. It does provide a lot of good information for diagnosing problems on the network. As pointed out in other comments, you need a lot more information to get to root cause but this should help you get started. Good luck. – Hogstrom Aug 13 at 11:35

Try going with another build number.

I have had this happen with a couple of atheros based routers, for whatever reason, it did only affect the MacBooks on the network.

What fixed it:

A different build number that users reported stable for the model router I was using.

Under wireless, setting the channel width to 20/40mhz dynamic mode. Enabling noise immunity for the radio under advanced wireless, and enabling radar detection (802.11h) under advanced wireless for the 5ghz band.

You may want to consider openwrt, the drivers, kernels, and pretty much everything about it is updated more frequently, and as a result, imo more stable.

Best regards,

  • Thank you very much for your feedback. I will attempt to make those changes and indeed maybe switch to openwrt. Downside is that if I switch to open-wrt that I would need to update the wireless settings on Nest things and wireless cameras. – Joel'-' Aug 20 at 8:40
  • You should take note of the settings that you have configured in dd-wrt, subnet, static IP mappings, port forwards, Mac filters etc etc. If you match your settings from ddwrt to openWRT you will be fine, the devices don't know the difference. – Tim_Stewart Aug 20 at 19:29
  • I just read your message. I have given up. Created a 2.4GHz virtual AP for just this one laptop. I'll live with it until I have enough time to take everything down and install OpenWRT. I do appreciate your efforts in helping me! – Joel'-' Sep 11 at 19:12

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.