2

When I use rysnc to backup my media hard drive that's plugged into my Ubuntu server using the command rsync -av --delete source destination it deletes and recopies all files that have accents in them, because of the nature of the way macOS handles accents in their filesystem.

How can I have rsync properly recognize these files and not copy them every time?

Example filename: Poke?\#201mon Black & White - Adventures in Unova - It's Always You and Me.mp3

3
  • @grawity I get an error when I try using that. rsync: --iconv=utf-8-mac,utf-8: unknown option rsync error: syntax or usage error (code 1) at /BuildRoot/Library/Caches/com.apple.xbs/Sources/rsync/rsync-52/rsync/main.c(1337) [client=2.6.9] – cclloyd Aug 13 '18 at 6:32
  • Your rsync 2.6.9 is too old. You need rsync 3.0 or later to use the --iconv option. – Marnix A. van Ammers May 7 '19 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.