6

After the version 68 update a couple weeks ago, my console in Devtools no longer clears after refreshing the page. Here are the console settings:

Chrome console settings

So unless I'm misunderstanding something, the console should be cleared upon refreshing the page, or navigating somewhere.

This was working fine until the version 68 update. (which broke the feature immediately, I noticed within a couple minutes since I use this console quite a bit)

Any reason that it wouldn't be clearing?

  • 2
    I have the same issue on my machine on Version 68.0.3440.106 – John Fu Aug 22 '18 at 2:05
  • @johnFu I finally tracked down the issue here. Hopefully my answer solves the problem for you too. – Skeets Sep 10 '18 at 4:44
5

Turns out the issue was an extention: "adBlocker Plus". I'm surprised I couldn't find many complaints about this issue.

I tested it about a dozen times. Disabling the extention fixes the problem.

I've had too many issues with AdBlock Plus in the past, so I'm switching to uBlock going forward. The same custom filters work, and it actually runs a little faster, too. :D

| improve this answer | |
  • hmm... I don't have ABP installed though. – John Fu Sep 26 '18 at 1:14
  • @JohnFu - bummer. You could try running in "incognito" mode (which by default disables all extensions and such). If it works in "incognito" mode, than that means an extension is probably causing the issue. – Skeets Sep 26 '18 at 1:46
  • @skeets how did you figure this out? – Dan Oswalt Nov 16 '18 at 21:04
  • @DanOswalt I disabled all extentions by trying incognito mode. When that worked, I Knew it was an extention causing the problem, so I disabled them one by one until I found the issue. – Skeets Nov 17 '18 at 23:47
  • 1
    I disabled the "AdBlock" extension and it fixed it for me (so different blocking extension but it still worked) - will give uBlock a go – Pete Nov 20 '18 at 11:07
1

I've run into this problem couple of times, but in my case I think it always happened after messing with debugger and it's settings.

I've fixed it by clicking "Restore defaults and reload" in DevTools settings.

| improve this answer | |
  • This actually solved it for me as well. – Adam Reis Oct 30 '18 at 22:03
  • just as an FYI to others, I tried this and it didn't work but I have AdBlock installed, so @skeets solution works for me – Pete Nov 20 '18 at 11:05
1

Got this error at v70. When I turned off all patterns in blackboxing setting this error gone

Screenshot of Framework Blackbox Patterns settings

| improve this answer | |
  • how to go to this settings, i can't see it in chrome settings – vikrant Apr 27 at 8:33
  • 1
    @vikrant devtools -> top right corner -> three dots -> settings – InoY Apr 27 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.