1

I have black bars on my video at the top and bottom. I changed the aspect ratio to 4:3 and crop ratio to 16:9 and it works when I watch it on my PC.

But when I uploaded the video to YouTube it stays the same, why? Should I convert the video? But when I do that the audio goes away from the file.

  • 1
    In general you should just not upload videos to YouTube which have black bars. If possible remove those black bars by using a video editing software of your choice (even Windows Movie Maker will do) and render the video as .mp4. Make sure you include the audio (if this is optional, otherwise it should be included anyways) and render the video at the resolution of your original footage without the black bars (e.g. 4:3 ratio might have a resolution of 1024×768). – FatalBulletHit Aug 14 '18 at 13:48
  • So isn't there a way to force the aspects ratio and crop ratio from the vlc itself? – user933740 Aug 14 '18 at 14:05
  • Don't really know about VLC's capabilites, but based on the answers below, I'd say, there is... :P – FatalBulletHit Aug 14 '18 at 19:13
0

Yes, VLC can create a permanently cropped video.

The tutorial "How to crop video using VLC media player" on steemit discusses the method.

It's not simple though. You need to set cropadd filter preferences, which you'll have to manually calculate, and then use VLC's Convert/Save menu item to record a new version of the video with those cropped settings.

I did this once. It wasn't entirely intuitive (especially trying to figure out what values needed to be set under cropadd), but it worked well.

Depending on your patience, however, it might be simpler to locate a different program that is more simply used for this purpose.

| improve this answer | |
  • The video cannot crop the black bars they just stay there. I set the aspect ratio to 4:3 and the crop ratio to 16:9 and that works (only in fullscreen but it's better than nothing, it would come out as black bars on the right side and left side and when it's fullscreen there won't be any bars ) how canI save that? I did convert once I forced the ratios but it's not working is there something I need to tick before converting? – user933740 Aug 14 '18 at 22:08
  • @user933740 I can't comment on what piece you might be missing. Did you modify the profile and select the crop filter before saving the video? Note that the aspect ratio has nothing to do with this process. So, maybe you're still only talking about viewing the video rather than going through that tutorial? – Jason Bassford Aug 14 '18 at 22:12
  • I did try to do the tutorial but in the end the crop isn't actually cutting the black bars but cutting the video itself that I want to view without the black bars. Right now the best thing that I found is when I set the ratios like I said it would at least show the entire video as fullscreen without the black bars. Before it was blackbars at the top and bottom in non fullscreen and in fullscreen but now with the ratios it shows blackbars on the right and left but it doesn't show them on fullscreen. That a little better. I want that, it's funny you can see it but can't save it. – user933740 Aug 14 '18 at 22:17
  • So, if the video is being cut, then it's just a matter of determining what values to put into the cropadd settings. That was the most difficult part for me. Can you tell me what the original dimensions of the video are (Tools > Media Information > Codec > Video resolution)—and what the aspect ratio is that you need to set under Crop in order for the bars to disappear when you view it? – Jason Bassford Aug 15 '18 at 0:01
  • Nevermind o finally managed the crop tutorial. I just needed a little time to finally do it. It was annoying increasing the numbers and decreasing them without cropping the actual video. Thx for the help! – user933740 Aug 15 '18 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.