The default behavior is history commands scrolling. Any way to change it?

2 Answers 2


I believe if you hold Shift down it will scroll the output and not simply cycle through command history.

  • 1
    If you're not sure, you should leave a comment for OP to verify. If it turns out to be helpful you can leave a full answer for OP to accept.
    – confetti
    Aug 15, 2018 at 10:25

This is not a default behaviour and cannot be configured using the UI / settings dialogue. You have to manually edit the ini-file.

  1. Close MobaXTerm, otherwise changes to the ini-file will be overwritten
  2. find the documents inside your user folder and got to the folder named MobaXterm
  3. open the file named MobaXterm.ini with a text editor
  4. look for the section called [Misc]
  5. in this section add a line like this:


Chosse a parameter that suits your needs: alt | ctrl | shift

  1. open MobXTerm again and scroll the window holding down the selected control key

see MobaXTerm-documentation here: https://blog.mobatek.net/post/mobaxterm-configuration-settings/

But heads up. This will probably still cause problems inside a screen session. You can fix this quick by pressing Ctrl + A and Esc or edit your .screenrc as described here:

termcapinfo xterm* ti@:te@ In tmux, it'd be something like (.tmux.conf):

set -g terminal-overrides 'xterm*:smcup@:rmcup@'

  • Works well, but not in tmux
    – diman82
    Feb 4, 2021 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.