0

I have a external HDD with 1 GB of memory. I have split it in two partitions: First one (from the start of memory addresses) has about 900 GB, and second has about 50 GB.

I installed linux mint on live usb (16 GB USB stick), restart my laptop, boot from that live USB stick, start installation from shortcut on the desktop.

During installation I splitted second partition (50 GB) to 4 partitions (as I saw in guide):

  1. Primary partition 10 GB for "/" mount point
  2. Primary partition 300 MB for "/boot" mount point
  3. Logical partition 4 GB for swap area
  4. Logical partition about 35 GB for "/home" mount point

After that I successfully installed linux mint on that partitions (it was \dev\sdc2 to \dev\sdc5), I choose \dev\sdc2 in installation manager.

After that I reboot my laptop, but In boot menu I can choise only "Internal SSD" or something like "UEFI File system". The second item of menu does nothing. I can only boot from internal SSD.

As result:

  1. On host OS (Windows 7) all drivers are work incorrect (after try to install Linux on EXTERNAL HDD)
  2. BIOS looks like it was updated with some UEFI stuff. (I have no UEFI before)
  3. I can see a newly created partitions on my external HDD from Linux live usb, and I can see files on those partitions.
  4. I can't boot from this partition, coz BIOS doesn't see it.

I think the problem in second partition, because in all guides I can find, uses disk instead of partition during installation (they use \dev\sdc, and I use \dev\sdc2), but I do not want to remove all my data on first partition.

I can't see an answer in documentation...

1

I think you have Win7 installed in legacy mode but installed Mint in UEFI mode. It's very hard if not impossible to have a working dual-boot with systems in different modes.

In your case, if the above assumption is correct, it's better to reinstall Mint in legacy mode* and make sure Grub is installed in the MBR of the internal drive. Result: Windows will always boot (from Grub) but Mint will only boot if the external drive is connected from the start.

  • Boot the Mint live USB in legacy mode to assure it installs in such mode. If there are two option about the live USB stick choose the one without UEFI.
  • Ok. It sounds helpful, but I do not want to have dual boot system. I want to boot from my primary Windows 7 system always. And only if I insert external HDD drive, and select it in "Boot options" during reboot, iI want to boot Linux. But I have hear you, about UEFI trouble. Thanks – gek0n Aug 15 '18 at 13:41
  • Booting Win7 by default requires editing Grub but it's possible unlike the other situation. No, the PC cannot guess what you want to do. Booting OSes independently is possible with UEFI but even with it it won't guess you want to boot Mint directly just by having the external drive connected. – GabrielaGarcia Aug 15 '18 at 13:50
  • Why not? If I choose external HDD as device for booting from? Only linux is on external drive, so boot loader can assume, that linux must be booted – gek0n Aug 15 '18 at 13:52
  • You can install Grub in the external drive MBR while keeping the original Windows bootloader in the internal drive. You would then set the firmware to boot from the internal drive normally (boots Win directly) but you would still need to change the first boot drive to the external one in order to boot Mint. It won't guess what you want just by plugging the external drive. – GabrielaGarcia Aug 15 '18 at 13:58
  • And I think, it would. Because if I set USB-HDD as first device in boot order, and internal HDD as second, when I try to load without plugged USB-HDD I just boot from internal drive. And when I plugged HDD - I will boot from USB-HDD. Am I wrong? – gek0n Aug 16 '18 at 6:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.