27

I have the same problem outlined in this forum thread - my Outlook shows the "Need Password" in the status bar:

enter image description here

But if I click it nothing happens, no dialog appears. There is also this button "Type Exchange Password & Connect":

enter image description here

If I click it a dialog briefly appears but then disappears. If I restart Outlook (close then open it) this fixes the problem for a time but then it appears again.

How do I manage to enter my account password so it stops asking me for it?

  • Is it possible that the dialog is hidden behind the Outlook Windows? Can you see the dialog via pressing Alt + Tab? Have you tried clearing the credential cache for your email account under Control Panel > Credential Manager? Besides, have a try with the workaround in this MS KB article to see the result: support.microsoft.com/en-us/help/4025962/… – Steve Fan Aug 16 '18 at 9:21
  • No, the dialog is not hidden, I checked with Alt+Tab and it is gone for real. I also tried clearing the credential cache but that didn't help either. – sashoalm Aug 16 '18 at 11:03
  • Kill (and if necessary restart) any instance of skype or lync. – Art Gertner Sep 14 '18 at 12:15

10 Answers 10

32

A collection of various known Outlook fixes for login problems :

  • Run Credential Manager, and if your account is listed ensure that it's correct.
    • If not correct, fix it.
    • If correct, try deleting it, reboot and log into Outlook.
  • Logging-in into Web Outlook might sometimes show an existing problem such as the need to change the password.
  • Start Outlook in safe mode by running Outlook.exe /safe and enter the ids if asked.
  • Unlink the Microsoft Account from Outlook
  • Disable Modern Authentication by regedit to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity, create a DWORD item named EnableADAL and set it to zero.
  • Under the same registry key, create a DWORD item named DisableADALatopWAMOverride and set it to 1. See Microsoft article.

Undo fixes which didn't help. You might also create a system restore point before starting.

  • 6
    DWORD key named DisableADALatopWAMOverride set to 1 worked for me. – Cory-G Nov 27 '18 at 0:09
  • For me Start Outlook in safe mode by running Outlook.exe /safe and enter the ids and password worked! Thanks! – S Nash Dec 4 '18 at 17:33
  • Setting DisableADALatopWAMOverride to 1 works for Okta login – Steven Apr 10 '19 at 3:38
  • 2
    Outlook safe mode worked for me. DisableADALaptopWAMOverride did not. EnableADAL worked for me (the permanent fix I settled on). Thank you, Harry – Frog Pr1nce Jun 21 '19 at 12:53
  • 1
    Going into Outlook /safe mode didn't work (I could enter passwords, but tried password a bunch of times and didn't take), but launching regular Outlook just after that did work... – Andrew Oct 31 '19 at 14:48
6

I had the same problem, and given that I have a corporate PC, I cannot do anything requiring admin privileges.

What worked for me: set in the Registry a DWORD value under HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity, named DisableADALatopWAMOverride and set it to 1.

A number of sources that deal with the issue follow. There are a few solutions proposed throughout, with a range of "upvotes".

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_win10-mso_o365b/outlook-password-window-disappears/62cf2b1a-ae26-45fc-95b1-c3c6cce0a188 (the accepted answer, with "28 people were helped by this reply", is the one I posted).

https://support.microsoft.com/en-us/help/4025962/can-t-sign-in-after-update-to-office-2016-build-16-0-7967-on-windows-1 (quoted in the first link).

https://office365.uservoice.com/forums/264636-general/suggestions/32694751-outlook-is-not-syncing-and-giving-a-need-password (quoted in the first link)

https://www.reddit.com/r/windows/comments/7g4tmo/help_outlook_2016_need_password_prompt_wont_allow/

https://community.spiceworks.com/topic/2109624-outlook-2016-needs-password-but-dialog-box-disappears

  • Setting this registry-key worked for me too. – Bert Verhees Sep 5 '19 at 8:14
  • This worked for me too. – Mihaimyh 18 hours ago
4

What worked for me on Windows 10 for my work account, no registry needed:

In Windows, go to Settings -> Accounts -> Access work or school, see if your account is listed there, other than the AD account. If so, remove it. Next time you open Outlook it should actually show the login dialog and try to connect.

Screenshot

  • Needs admin . . – Andrew Oct 31 '19 at 14:47
3

You might need to try to run an office repair as this issue is caused when the password across the Office 365 suite is not sync'd. Goto Control Panel, Program and Features, right click on Office, click on change and then Quick repair

Alternatively you may try creating a new profile for Outlook as well. This can be achieved by typing mail 32 in the search box of the start menu. Click on New and then create a new profile.

  • I ran Quick Repair and it's working but I'll have to wait and see if the problem reappears later. – sashoalm Aug 15 '18 at 15:57
  • Sure thing, this happens a lot on Exchange based accounts. Reply to this thread in case you face any issues. – CAO Aug 15 '18 at 16:15
  • Hi again. I got the same problem today (Need Password) so I think repairing did not fix it or fixed it only temporarily. – sashoalm Aug 16 '18 at 8:07
  • Then you might need to logout from one of the Office apps(excel word etc) and sign back in. If it does not work then I will create a new profile in Outlook. – CAO Aug 17 '18 at 12:08
3

Disable Modern Authentication by regedit to HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity, create a DWORD value named EnableADAL and set it to zero. Under the same registry key, create a DWORD value named DisableADALatopWAMOverride and set it to 1. See Microsoft article.

this is wrked for me thanks

  • It looks like MS asks for Accept permissions for some new "Getting better together" and Privacy Policy data. If You are not logged into WEB, Outlook does not display these popupscreens correctly. This helped for me! Thanks! – Arnis Juraga Aug 29 '19 at 11:37
2

I found removing the MS account would work for this sometimes but I also found another aspect that helps. Manually removing the product key registered on the PC has fixed this for me after signing out from the O365 account.

use the cscript.exe and ospp.vbs to remove the programmed key and log backin when relaunching.

  1. Make sure to sign out from the Office account and that all O365 apps are closed
  2. open an admin/elevated cmd prompt
  3. This varies based on version and 32 or 64 bit version of Office installed. The standard entries for o365/2016 are listed below.

    a) enter into the admin cmd prompt and enter the following command - it will provide license info for what's registered in o365 and the last 5 digits/characters so you can use them in the next step cscript.exe "%programfiles(x86)%\Microsoft Office\Office16\ospp.vbs" /dstatus

b) now take 5 digits of the key provided for whichever subscriptions are registered and use this command with all of them or you can do it one at a time until it works with xxxxx representing the key being removed- cscript.exe "%programfiles(x86)%\Microsoft Office\Office16\ospp.vbs" /unpkey:xxxxx (fixed spelling mistake in this)

4) Open Outlook and you should be prompted to login.

1

I had the same problem. After going through all of the suggestions on many of these forum sites, I was able to remedy the problem.

I used a built-in Windows function as follows:

Step 1: Go to the Windows Control Panel and click "Programs and Features". Step 2: Right-Click on "Office 365" (in my case) and select "Change" in the drop-down list. Step 3: Click the bullet for "Quick Repair".

After the quick repair was complete, I reopened Outlook and all was good.

1

for those that have tried all the above and still had the issue. I found completely uninstalling, removing credentials etc the whole lot from the PC. Then removing the users 365 license from the 365 admin portal for an hour before re-applying and reinstalling, did the trick for me.

1

Workaround that worked for me:

1) Press on help --> Contact Support Screenshot

2) Write anything in the popup window and then press Get Help. Screenshot

3) SignIn button will appear, Press on it and then choose to logout.

4) Sign in again in the helping popup window.

5) Close Outlook and reopen it --> Now it's should work.

1

In my case, this happened due to a company-driven automatic update to Outlook that I originally wasn't aware of. The fix was to simply restart the computer!

Figured I would post another possible solution in case this helps anyone else.

Not the answer you're looking for? Browse other questions tagged or ask your own question.