8

Question:

I am trying to update one of my Windows 10 operating system, but it has been stuck in Initializing status.

The update in question is: [Internal – Corpnet Required] 2018-08 Cumulative Update for Windows 10 Version 1803 for x64-based Systems (KB4343909)

windows update stuck

I tried to search for [Internal – Corpnet Required], but there are no results. I'm not sure why Windows Update is stuck. The strange thing is, I was able to successfully install update (KB4343909) on my other Windows 10 machine.

Does anybody know what [Internal – Corpnet Required] is? And why it would be causing my windows 10 update to be stuck in Initializing status?

Here is the result of running winver:

winver

Update:

Running the Fresh Start utility seems to have fixed my issue with Windows Update.

windows 10 update is fine now.

Update 2: After running the Fresh Start utility, I reinstalled software on Windows 10 such as TeamViewer, Visual Studio 2017 Community Edition and SQL Server 2017 Developer Edition. Afterwards, I am getting the same Windows 10 Update issue all over again.

same problem again

12
  • 1
    Can the machine access the corporate network? Also, have you tried downloading KB4343909 from download.windowsupdate.com/c/msdownload/update/software/secu/… Aug 15, 2018 at 18:27
  • I'm not on a corporate network. It is my home network and the Windows 10 is running as a guest OS under VirtualBox. I have 2 additional Windows 10 running under VirtualBox that are able to update just fine. I will try to download KB4343909 and report back with my findings.
    – kimbaudi
    Aug 15, 2018 at 18:41
  • 2
    I'm voting to close this question as off-topic because the user ran the Fresh Install utility, which means their installation was wiped, which means this issue no longer exists and cannot be reproduced. Furthermore, the problem was solved by running the utility, so any solution suggested in an answer cannot be verified.
    – Ramhound
    Aug 15, 2018 at 20:24
  • 1
    @fixer1234 - I updated my question because running Fresh Install did not resolve the issue. After I installed software such as VS 2017 Community and SQL Server 2017 Dev Edition, Windows Update problem persists.
    – kimbaudi
    Aug 16, 2018 at 1:10
  • 1
    @PimpJuiceIT - I followed Method 10 from the link you provided and it solved the Windows Update issue I was having. It was the same method that was suggested to me earlier today by harrymc. Thank you!
    – kimbaudi
    Aug 16, 2018 at 5:01

3 Answers 3

3

When having problems with Windows Update, here are a few possible actions:

  • Run PC Settings, Update & Security, Troubleshoot, and choose Windows Update

  • Run Microsoft's Windows Update Troubleshooter

  • sfc /scannow - check Windows integrity.

  • After resetting Windows Update as in the first point above, rename C:\WINDOWS\SoftwareDistribution\Download as explained in this answer and reboot. If this doesn't help, redo again but rename instead C:\WINDOWS\SoftwareDistribution and reboot.

3
  • I already tried running Windows Update Troubleshooter by going to Settings -> Update & Security -> Windows Update. However, it just resets the Windows Update and when I click 'Check for Update' button, it shows the same screenshot that I posted.
    – kimbaudi
    Aug 15, 2018 at 19:49
  • 1
    After resetting Windows Update, rename C:\WINDOWS\SoftwareDistribution\Download as explained in this answer and reboot. If this doesn't help, reset again and execute again this procedure but rename instead C:\WINDOWS\SoftwareDistribution and reboot.
    – harrymc
    Aug 15, 2018 at 19:55
  • I ran into this issue again after running Fresh Install. So I ran sfc /scannow as admin user and there was no issue. So then I renamed C:\WINDOWS\SoftwareDistribution\Download and Windows Update issue is resolved. Thank you!
    – kimbaudi
    Aug 16, 2018 at 4:59
0

One of my machines at home had the same issue.

In brief

I executed the following steps to solve the issue.

Step 1: Reboot in Safe Mode with Networking

Step 2: Settings > Update & Security > Troubleshoot > Windows Update > Run the troubleshooter

Step 3: Apply fixes

Step 4: Reboot (start windows normally)

Step 5: Set the correct time zone (make sure your machine has the correct time zone)

Step 6: Settings > Update & Security > Windows Update (if its downloading updates, let it finish. The update with indication [Internal – Corpnet Required] should have a link below it Retry. Click Retry when the update service has finish installing all other updates.

3
  • 1
    Running the troubleshooter in safe mode returns "Troubleshooting couldn't identify the problem".
    – DuCorey
    Aug 15, 2018 at 23:45
  • This problem appeared to me last night while I was formating a computer at home. I remember that on step 3 while troubleshooter wizard was applying the fixes, it was displaying some progress messages. One of those messages was rebuilding updates database (it took about 4-5 minutes for the fixes to apply). I have 2 more windows 10 machines at home but none of them had this issue. It's really weird. The aforementioned steps was the solution in my case, so I wrote them down. The only thing I want to ask you, you were running the troubleshooter in Safe Mode with Networking ? Aug 16, 2018 at 7:37
  • Step 1: support.microsoft.com/en-us/help/12376/…
    – gReX
    Oct 15, 2019 at 15:18
-1

Tried above method (safe mode etc) and it didnt work, Just spoke with Microsoft, this issue can only be fixed by reinstalling Windows, need to create NEW USB media via media creation tool April 2018 edition as it has newer updates imbedded.

For some reason, the update tasks in services.msc are being stopped when this "Internal - Corpnet" update tries initializing. If you go to services.msc you will see BITS stopped. The Microsoft support live help changed this via remote access and it still didnt fix the issue so he recommended a new media creation install.

Download latest Windows 10 media creation tool (USB media creation also available) here: https://www.microsoft.com/en-au/software-download/windows10

Edited: The new install did not work :( Back on the phone to Microsoft.

9
  • Can you provide a link to the tool? I'm having this same issue and I just reinstalled windows less than 24 hours ago using MediaCreationTool1803 from microsoft.com/en-ca/software-download/windows10.
    – DuCorey
    Aug 15, 2018 at 23:51
  • no worries at all, glad to help.... microsoft.com/en-au/software-download/windows10 Aug 15, 2018 at 23:57
  • It looks like there are some less traumatic fixes in other answers that may work in some cases. You aren't clear on what may have been ruled out on your system before MS recommended reinstalling. Also, the MS support people have a vested interest in solving your problem quickly rather than by the least destructive method. This information is good to know, but people may want to try other things first, and save the big hammer in case the others don't work.
    – fixer1234
    Aug 15, 2018 at 23:58
  • Yes, thats true however sometimes "Less destructive" methods can often be less successful in the long run. Aug 16, 2018 at 0:01
  • I seriously have doubts the only way to do this issue is a nuke your windows install. I have about 5 different solutions but the author wiped their system so none of them can be tested.
    – Ramhound
    Aug 16, 2018 at 0:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.