3

Many applications windows are scaled down to about two thirds of original size on my system (a laptop with two external monitors) and also on one another (also a laptop, but with a single external monitor).

For example, if I open a 1920x1080 PNG picture in Paint and maximize it on the middle monitor (that has native 1920x1080 resolution and is set to that resolution in Windows, with 100% scaling), the picture will not take up the entire window, but seems to be scaled down to about 66%.

What could be the cause and how to fix it?

It is Windows 10 Home 64 bit (up to date, version 1803).

The laptop monitor is 1920x1080 with 150% scaling and the third monitor is 3440x1440 at 100% scaling.

Logging out and back in does not help, neither does rebooting.

Screenshots:

MS Paint showing own screenshot sized 1920x1080 but scaled down:

MS Paint showing own screenshot sized 1920x1080 but scaled down

TeamViewer showing a 1920x1080 remote screen, yet smaller that local 1920x1080 monitor, even if set to 1:1 scaling: TeamViewer showing a 1920x1080 remote screen, yet smaller that local 1920x1080 monitor, even if set to 1:1 scaling

  • When you adjust scaling, then sign out and log back in, what happens? – music2myear Aug 15 '18 at 21:44
  • Don't know why it's happening or how to fix it, but 66% is exactly what you'd expect if the window was translated from full screen on the laptop monitor to the middle monitor and rescaled back to 100% (from the 150%). To see if this is the reason, try setting the scaling of the laptop monitor to 100% to see if that fixes the issue. – robinCTS Aug 16 '18 at 8:08
  • @music2myear I did not try that, but I reproduced the problem on another PC (laptop with one external monitor). So it seems to be a "standard" "feature" of Windows 10 to scale things down in such setups. – David Balažic Aug 17 '18 at 12:03
  • @robinCTS I will suggest that to the owner to try, but that can not be a permanent solution, as the laptop has a14 inch display with 1920x1080 resolution and things would be super tiny that way. – David Balažic Aug 17 '18 at 12:08
  • Windows does apply scaling automatically on high pixel-density screens. For instance, on a 20" 1920x1080 monitor, Windows applies on scaling by default, but on a 10" 1920x1080 monitor, Windows will apply 150% scaling by default. Same resolution, but higher density on the smaller screen, and scaling is applied. When scaling is applied, you MUST sign out and back in (or restart) to properly complete the scaling procedure. Until you sign out and back in scaling will be inconsistent. – music2myear Aug 17 '18 at 15:24
1
+50

This is a typical problem with Windows 10. Try resetting scaling to 100% for all three screens and then check again.

For that you need to visit the Display settings (right click the desktop to see this option) and select each monitor and set scaling to a 100%.

If it still doesn't work then probably your monitors are of higher resolution and set to a lower one in Windows

  • The monitors are at correct resolution, also as seen in the screenshot, Windows also "thinks" the middle monitor is 1920x1080 (the size of the screenshot). – David Balažic Aug 23 '18 at 19:48
  • I reproduced the problem in VirtualBox. Installed win10 and created a main display of 1920x1080 with 150% scaling and another one with 1920x1080 and 100%. Running Paint on the second monitor behaves exactly as in the question. (if anyone supplies an actual solution, I'll select it as the correct answer, but I gave the bounty here) – David Balažic Aug 24 '18 at 20:00
  • Forgot to mention: setting scaling on all displays to 100% mitigates the problem. – David Balažic Aug 24 '18 at 20:18
0

Your scalings are inversed :

The monitor with resolution 1920x1080 should be scaled as 100% (unless physically small), while the monitor with resolution 3440x1440 should be scaled as 150% (or as whatever scaling makes the desktop text readable).

If any one application is not obeying the scaling rules and its screen is too small and hard to read, the following might help in allowing Windows to modify the screen :

  • Find the .exe file of the application
  • Right-click it and choose Properties
  • Go to the Compatibility tab
  • Click Change high DPI settings
  • Check Override high DPI scaling behavior
  • Choose System (Enhanced) in the drop-box
  • Click OK twice.
  • Why? The laptop monitor is 157 DPI, the middle is 96 DPI and the "big" one is 110 DPI. The scalings of 150%, 100% and 100% are the closest to perfect they can get. – David Balažic Aug 23 '18 at 19:46
  • Scaling above 100% is for increasing the font size for text which is unreadable on a high-resolution screen such as 3440x1440. It is not required for a normal-resolution screen such as 1920x1080 (unless to aid poor personal vision). – harrymc Aug 23 '18 at 19:57
  • Without (up)scaling you need a microscope to read anything from 1920x1080 on a laptop screen that is sized 14 inches. – David Balažic Aug 23 '18 at 20:03
  • Right, then it also needs to be up-scaled. In any case, the 3440x1440 monitor should not be at 100%. – harrymc Aug 23 '18 at 20:07
  • I have added more info which might be useful. – harrymc Aug 24 '18 at 5:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.