When connected to AC power, my Lenovo T440s (2014) intermittently switches from "charging" to "discharging", and very quickly back to "charging". A full cycle takes just a few seconds (anywhere from about 4 seconds to about 8 seconds).

A consequence of this is that my total charge decreases over time, even when plugged in. In fact, it seems to decrease approximately as quickly as when not plugged in at all.

I instrumented this with:

while true; do
    upower --dump | grep state | tail -1 | awk '{print $2}'
    sleep 0.2
done |
stdbuf -o0 awk '{ if ($1 != last) { last = $1; print last } }' |
ts '%b %d %H:%M:%.S'

yielding output like:

Aug 16 17:48:02.048372 charging
Aug 16 17:48:05.610427 discharging
Aug 16 17:48:06.277114 charging
Aug 16 17:48:09.813108 discharging
Aug 16 17:48:10.259273 charging
Aug 16 17:48:14.019795 discharging
Aug 16 17:48:14.468673 charging
Aug 16 17:48:18.244860 discharging

I’ve tried this in three battery configurations:

  • internal battery only;
  • internal battery plus a 72Wh Li-ion external battery;
  • no internal battery (physically disconnected), external battery only.

The problem persists in all cases.

The problem occurs in both Linux Mint 18.2 (Xmonad) and Windows 10, as well as in the BIOS and when the machine is powered off (the power light blinks every few seconds to indicate that the machine has been “plugged in”).

This originally happened with a power adapter that was approximately a year old. I purchased a new power adapter; the problem continues.

What might be the problem? How might I fix it?

  • (1) Did that, even in different cities. (2) Did that, no change. (3) The cord and power adapter are brand new (less than a week old), with no apparent damage. I didn't see anything suspicious inside the case. (4) All BIOS tests (motherboard and CPU included) pass. – wchargin Aug 17 '18 at 4:17
  • Good job, process of elimination!!. – Pimp Juice IT Aug 17 '18 at 4:20

I took the machine to a computer repair shop. They diagnosed the problem as a bad surface-mounted capacitor on the motherboard. Replacing the motherboard solved the problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.