1

After updating my linux-headers, I recognized problems with an old version that also blocked apt-get. I tried to remove the sources manually but I'm stuck at this point.

cd usr/src/linux-headers-4.13.0-36/drivers/pci/switch/Makefile/
sudo rm switch

throws the error

rm: cannot remove 'switch': Too many levels of symbolic links

Here is what I've tried, after googling around, but none of it worked:

sudo rm -r switch
sudo rm -R switch
sudo chmod 666 switch
sudo find -L ./ -mindepth 10
sudo unlink switch

the answer was always "Too many levels of symbolic links".

When I do ls -al I get

d????????? ? ?    ?       ?            ? switch

What is wrong with the file, or how can I diagnose it? How can I delete it? Thank you for your help!

1

After I rebooted the machine, I booted into the (initramfs) console. There this answer helped me. While repairing my sda1 with the command I had to repair INodes and some other blocks.

fsck /dev/sda1

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.