1

I'm using VeraCrypt which creates a file with a fixed size and shows no signs of modification after the decrypted content is edited. It's part of its purpose to behave this way, problem is, you need backups.

Backup softwares I have tried (SyncBackFree and Bvckup) do not 'understand' the file has been modified and do not copy it.

Any ideas, besides manually copying it ?

  • Some backup software checks the "archive" file attribute status for files selection (the attribute is unset after a successful backup), you could try to set such attribute manually and then, if it works, to schedule a task for such activity. – ciarpame Aug 17 '18 at 13:03
2

Actually it is a feature that prevent revealing when container was used last time.

If you don't need such behavior simply disable it and backup software should recognize then modification time:

enter image description here

  • That was silly. I had explored vera's settings, but didnt recognize the solution. What did you use to create the gif ? In case you have used veracrypt for some time, have you had any accidents, ie corrupted containers not opening with the right password ? – alfred Aug 18 '18 at 11:15
  • I got this gif from here. As about VeraCrypt, I using it a lot on shared servers, no problem so far. It very robust solution if you would take some precaution, so even in case of light container damage you may still get access to it. Check this related thread: security.stackexchange.com/a/128232/106879 – Alex Aug 18 '18 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.