Anytime I try to download a theme from the Windows 10 App store I get an error "something happened" error 0x80070781 and all I can do is press the OK option. I tried to the wsreset.exe and some other options that involve powershell scripts, however, these end up generating an error stating that the Windows store app needs to be closed. Here is the example of the script I tried with no success:

Get-AppXPackage *WindowsStore* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} 

I've read somewhere that the one possible solution is to copy a working version of the WindowsApps Folder to my machine? Is this correct?

  • Thanks for your reply. I copied and tried your new PowerShell script and here is the error message I get: Get-AppXPackage : Access is denied. Access is denied. At line:1 char:1 + Get-AppXPackage WindowsStore -AllUsers | Foreach {Add-AppxPackage - ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Get-AppxPackage], UnauthorizedAccessException + FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.Windows.Appx.PackageManager.Commands.GetApp xPackageCommand – Bturner1968 Aug 19 '18 at 17:18
  • Have you tried the Windows Store apps Troubleshooter? Windows Store Apps Troubleshooter in Windows 10 Fixes Apps Download and Install Problems – w32sh Aug 19 '18 at 17:53

There are several reasons for this error. It maybe caused by account itself, update or Windows store APP.

  1. You can try to change an account to login and download.
  2. Check if update is normal, disable the firewall and anti-virus software.
  3. Run the windows APP troubleshooter and help you detect the problem with the store APP.
  4. Reinstall the windows 10 store APP.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.