For some reason I don't get any vertical scrollbars in powershell, and I cannot scroll up to see any commands or output after they've gone out of view.

I can't see the output from my commands if it doesn't all fit on the screen at once.

Does anyone know what I might need to do to fix this?

I can't see any settings in powershell properties to enable or disable vertical scrolling.

If I normalise the window size, it shows the scrollbars, but will only allow scrolling the equivalent maximised size.

2 Answers 2


I found the solution. I had to increase the Height in "Screen Buffer Size" under "Layout" tab in properties.


settings -> profile -> windows power shell -> advanced ( at bottom ) -> history buffer size -> 999999

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.