5

I moved the location of my OneDrive Personal folder from the user-specific folder to C drive.

However Windows 10 was not able to search in this folder, so I thought I would add the folder manually to indexing option.

But this folder is not on the list.

  • Adding the OneDrive temp folder does nothing

  • Dropbox indexes well after being added to the list

Can you help?

enter image description here

7
  • Try to add indexing attribute with this command as administrator: attrib C:\OneDrive +I.
    – Biswapriyo
    Aug 21, 2018 at 13:25
  • Does the "Show all locations" button help? Aug 21, 2018 at 13:29
  • thanks guys. Tried both options. adding attribute is via cmd right? @Biswapriyo? Nothing changes after that.
    – Freelensia
    Aug 22, 2018 at 16:06
  • Are you using the Administrator account to sign in this computer? Try to log on Windows 10 with higher permission, then try to add Indexed location.
    – WinniL
    Aug 24, 2018 at 8:58
  • I am in an admin acct, @WinniL
    – Freelensia
    Aug 25, 2018 at 9:37

4 Answers 4

4

I experience the same issue. I keep my OneDrive folder on drive D. After setting it up in another location you cannot add that location to indexing, it simply does not show up in the folder tree. So far my workaround is to create a folder first, than add that folder to indexing and only after that I set up OneDrive to use that folder. It is indexed but still disappears from indexing options after OneDrive setup. But that way you lose the ability to index only necessary folders within OneDrive folder. All of its content is indexed regardless whether you need it to be indexed.

5

Excuse me for the late response, but the question is still relevant.

After disabling the Files on demand in OneDrive settings, the folder will appear in the Indexing Options.

-1

I'm late to the answer party in this thread, but my answer is still relevant and I hope it helps someone:

I found a solution to OneDrive not being included as part of Windows Search Index. You can keep your files in the cloud, and where they are now, and this still works.

For any folder you want to be part of Windows Search Index, OneDrive folders included... you need to change the permissions, and possibly ownership. I changed all my searchable folders to add "Everyone", with "full control".

Your computer may choke on doing this to one very large OneDrive folder and if it does, just do one smaller folder at a time.

You'll immediately see that those folders are now searchable via your Windows key, and typing a few letters.

NOTE that you still won't see the OneDrive folder as an selectable option under Windows Search options! It doesn't matter. Windows will index it regardless. As for that "Don't use the index when searching in file folders for system files..." check box found under "File Explorer Options" (found only from a File Explorer window)... it doesn't seem to make a difference for me. I have it UNCHECKED and it works great. Changing the folder permissions did make a difference tho.

ANOTHER NOTE... I did make sure Windows was logged into my account that is the same as my OneDrive folder. But I'm not sure that helped. Changing permissions did.

Here's the path to changing the PERMISSIONS for a folder:

RIGHT click the folder and go to Properties - Security tab - Edit (under Group or user names) - Add - Advanced (button at the bottom left) - Find Now (on the right side) - in the list find and double-click "Everyone" - Press OK - Click on Everyone - click on the Full Control and Modify check boxes below - click ok.

IF YOU GET ERRORS trying to change permissions, just tap to continue anyway. If you are desperate to just get it done, you have to change the OWNERSHIP of that folder. I changed it, like the files, to 'everyone' (yes, some will argue that unsafe to do, but hey, it's my PC and I'm ok with that)

Here's the path to changing OWNERSHIP of your files and folders:

Right click the folder and go to Properties - Security tab - click Advanced near the bottom - at the very top will show Name: xxxx and Owner: xxx CLICK on the blue highlighted "Change" - Advanced - Find Now - double-click on Everyone in the list below - Press OK - check the box at the top for "Replace owner on subcontainers and object" - Press OK ... and away it goes. THEN try to change security for all files and folder. It should work now.

1
  • Identical answer on another question and it is sort of looking like chatgpt Jan 12 at 4:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .