-1

Trouble with IPv6 under KVM host with bridge on Centos 7

I have ip6tables that are cleanly flushed with:

#> ip6tables -F

ND should be allowed

Then, if I do:

#> ip -6 neigh
2a0d:2407:14::1 dev vmbr0  router FAILED

Router is in a failed state

SYSctl information

#> sysctl -p
net.bridge.bridge-nf-call-iptables = 1
net.bridge.bridge-nf-call-ip6tables = 1
net.ipv6.conf.default.forwarding = 1
net.ipv6.conf.all.forwarding = 1
net.ipv6.conf.default.proxy_ndp = 1
net.ipv6.conf.all.proxy_ndp = 1
net.ipv6.conf.vmbr0.disable_ipv6 = 0
net.ipv6.conf.vmbr0.autoconf = 1
net.ipv6.conf.vmbr0.accept_ra = 1
net.ipv6.conf.vmbr0.accept_ra_defrtr = 1
net.ipv6.conf.em1.disable_ipv6 = 0
net.ipv6.conf.em1.autoconf = 1
net.ipv6.conf.em1.accept_ra = 1
net.ipv6.conf.em1.accept_ra_defrtr = 1

Adding +1 IPv6 IP

ip -6 addr add 2a0d:2407:14:b::a1/48 dev vmbr0
ip -6 route add 2a0d:2407:14::1 dev vmbr0
ip -6 route add default via 2a0d:2407:14::1 dev vmbr0

or via a file

IPV6INIT=yes
IPV6ADDR=2a0d:2407:14:b::a1/48
IPV6FORWARDING=yes
IPV6_DEFAULTGW=2a0d:2407:14::1
IPV6_DEFROUTE="yes"
IPV6_AUTOCONF="yes"

/etc/sysconfig/network

NETWORKING_IPV6=yes
NETWORKING=yes
IPV6FORWARDING=yes

Bridge is working as expected

vmbr0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet X.224.131.100  netmask 255.255.255.255  broadcast X.224.131.100
        inet6 2a0d:2407:14:b::a1  prefixlen 48  scopeid 0x0<global>
        inet6 2a07:a907:50a::1001  prefixlen 48  scopeid 0x0<global>
        inet6 fe80::222:19ff:fe69:e605  prefixlen 64  scopeid 0x20<link>
        ether 00:22:19:69:e6:05  txqueuelen 1000  (Ethernet)
        RX packets 743076424  bytes 313370954751 (291.8 GiB)
        RX errors 0  dropped 18329  overruns 0  frame 0
        TX packets 185499485  bytes 141916131563 (132.1 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Ping6 google.com

ping6 ipv6.google.com
PING ipv6.google.com(ams15s21-in-x0e.1e100.net (2a00:1450:400e:800::200e)) 56 data bytes
From fe80::222:19ff:fe69:e605%vmbr0 (fe80::222:19ff:fe69:e605%vmbr0) icmp_seq=1 Destination unreachable: Address unreachable
From fe80::222:19ff:fe69:e605%vmbr0 (fe80::222:19ff:fe69:e605%vmbr0) icmp_seq=2 Destination unreachable: Address unreachable
From fe80::222:19ff:fe69:e605%vmbr0 (fe80::222:19ff:fe69:e605%vmbr0) icmp_seq=3 Destination unreachable: Address unreachable
From fe80::222:19ff:fe69:e605%vmbr0 (fe80::222:19ff:fe69:e605%vmbr0) icmp_seq=4 Destination unreachable: Address unreachable
^C
--- ipv6.google.com ping statistics ---
6 packets transmitted, 0 received, +4 errors, 100% packet loss, time 5000ms

Pinging Gate (Fun begins) After a couple of pings (usually 5-6) gate stops responding and consecutive pings do not go through.

#> ping6 2a0d:2407:14::1
PING 2a0d:2407:14::1(2a0d:2407:14::1) 56 data bytes
64 bytes from 2a0d:2407:14::1: icmp_seq=1 ttl=64 time=20.8 ms
^C
--- 2a0d:2407:14::1 ping statistics ---
7 packets transmitted, 1 received, 85% packet loss, time 6000ms
rtt min/avg/max/mdev = 20.877/20.877/20.877/0.000 ms

Route 6

#> ip -6 route
unreachable ::/96 dev lo metric 1024 error -113
unreachable ::ffff:0.0.0.0/96 dev lo metric 1024 error -113
unreachable 2002:a00::/24 dev lo metric 1024 error -113
unreachable 2002:7f00::/24 dev lo metric 1024 error -113
unreachable 2002:a9fe::/32 dev lo metric 1024 error -113
unreachable 2002:ac10::/28 dev lo metric 1024 error -113
unreachable 2002:c0a8::/32 dev lo metric 1024 error -113
unreachable 2002:e000::/19 dev lo metric 1024 error -113
2a0d:2407:14::1 dev vmbr0 proto static metric 425
2a0d:2407:14::1 dev vmbr0 metric 1024
2a0d:2407:14::/48 dev vmbr0 proto kernel metric 256
unreachable 3ffe:ffff::/32 dev lo metric 1024 error -113
default via 2a0d:2407:14::1 dev vmbr0 metric 1024

What else am I missing in the configuration which would enable IPv6 connectivity on the machine?

Beforehand thanks for your time looking at this.

  • Confirm with your datacenter the correct IPv6 netblock and gateway address assigned to your server. If they are correct, this may be a problem with their equipment. – Michael Hampton Aug 26 '18 at 20:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.