1

As a possible solution to a previous question, it was suggested to update the bios of my Asus Eee Pc 1001 PXD with Lubuntu 16.04. As stated in this FAQ on the Asus website, I downloaded the latest version of the bios and firmware update from the website, created a Fat16 USB and copied the ROM file in the USB with the correct name "1001PXD.ROM". Then, I have switched off my PC, inserted the USB and entered the EZ-Flash utility for updating the bios.

The first strange thing is that if the only Fat16 partition of my USB is larger than 1Gb, the system will not find the USB device, while if I force the partition to be smaller than that, the screen reads "USB Device found."

After this, it shows the message:

Reading file "1001PXD.ROM"

and it does not move from that message for more than 45 minutes (after that time, I assumed the system to be stuck and I rebooted it). In this time, the led of the USB device, after a few flashes in the first seconds in which the message is shown, is always switched off.

I have also tried with the penultimate version of the update instead of the latest one, but the same problem occurs.

Does anyone have any suggestion for correctly updating the bios?

  • 1
    It show work in FAT16 but the any firmware - BIOS or UEFI - allowing the use of USB media for that purpose, has been optimized for the standard FAT32 that all up to 32GB sticks come factory formatted with (and the partition size doesn't matter). – user931000 Aug 24 '18 at 17:30
  • Also the Asus guide you linked says nothing about changing the file's name. Is it possible you're trying to use a wrong firmware? – user931000 Aug 24 '18 at 17:32
1

You have to change the file name to "1015PE.ROM".

  • Hi Rafael, welcome to superuser! Your post could do with some more details on Why the Author needs to do it this particular way. Be sure to check out the Answer section to get some helpful tips on how to write the best answers, thanks for your contribution! – angelofdev Sep 10 '18 at 5:14
  • Can you explain your answer, and/or link to a relevant reference? – Scott Sep 10 '18 at 5:15
0

Use a standard FAT32 formatted USB stick.

https://www.asus.com/Laptops/Eee_PC_1001PXD/HelpDesk_BIOS/

The above link is where you can download the only BIOS version (0703) published by Asus for you model.

According to the guide linked in the question, just download the ZIP file and extract its contents - a single file named 1001PXD-ASUS-0703.ROM - to the root of the USB stick.

  • Unfortunately, formatting the USB in FAT32 makes it not recognizable from my EZ-Flash. I don't actually know why. – JackI Aug 24 '18 at 18:40
  • Some USB sticks just don't work for this purpose and/or as bootable devices for live sessions or OS installation. What are the brand, model and size of your USB stick? – user931000 Aug 24 '18 at 18:42
  • I have tried three different USB sticks and two of them were previously been used for installing Lubuntu (at least four times). All of them have troubles with big partitions and FAT32 partitions, all of them can be correctly found for small FAT16 partitions. – JackI Aug 24 '18 at 19:02
  • Any 64GB or higher capacity require exFAT due to FAT32 partition size limitations. exFAT cannot be used but with just ONE FAT32 partition of pretty much any size it should work. Or use a smaller stick instead. There's really not other hypotheses I can think of, it's either what I've been telling you, or your ancient laptop has problem (very likely) or the format process has been done incorrectly. – user931000 Aug 24 '18 at 19:12
  • All of them are smaller than that. One is 1Gb, the second is 2Gb and the last is 16Gb. Probably there is something wrong in my computer. – JackI Aug 24 '18 at 19:16
0

I had very same problem. Checked a 5 different usb and failed. In the end i found answer on some forum that guy faced issue until he used a really old usb stick. In my case 32kb allocation fat16 on sdcard 2gb taken out from old cannon camera helped. I had to rename also 1001PXD-ASUS-0703.ROM into 1001PXD.ROM. Then normal alt -f2 during bootup did the trick.

Original forum i found information on https://www.elektroda.pl/rtvforum/topic3163789.html (in polish)

Good luck (if you still trying;) its been a while since post)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.