I use Kubuntu. Sometimes after after I run a program from the terminal window and then kill it, I can no longer see what I'm typing.

The terminal window continues to function, and if I run 'ls' I get a listing as normal. The only strange thing is that I can't see what I type.

Any ideas what how to resolve this?


Try to reinitialize your terminal. Use the reset command.

  • Now, if I only knew how to recreate this scenario I could test it right away. Thanks. – DanJ Apr 27 '10 at 15:31

This can happen if/when the program you were in has changed your terminal's "stty" settings. In particular one of the things that probably changed was that 'echo' was turned off. Programs should notice when they're interrupted and set your terminal back to how it was, but if they're not set to do so or if they're killed with a 'kill' signal, then your terminal is left without echo mode on and often with other terminal settings changed as well. To get back to normal settings, you can enter the command 'stty sane'. Because other settings besides 'echo' may have changed, you may need to end that command with a control-J (line-feed). I would go ahead and always just do "stty sane" followed by a control-J .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.