I have purchased a certificate from godaddy, which is now in .pfx format. I tried to convert it into .cer using Internet Explorer and Firefox. I tried to to sign midlet using converted .cer, but I get following error message:

The KeyStore does not contain private key associated with this alias !! Cannot sign

How to get work done?


There is a Stackoverflow Question on this with a OpenSSL based answer.

from there,

openssl pkcs12 -in xxxx.pfx -out mycertificates.crt -nokeys -clcerts
  • "java.security.cert.certificateParsingException Invalid der encoded data." getting this message. – jmj Apr 28 '10 at 4:23
  • i tried doing this but when i select export private key , i am getting .cer (DER encoded) option disabled . and midletsigner utility need provatekey anyhow.. – jmj Apr 28 '10 at 4:39
  • solved this issue with.. Keytool –importkeystore –srckeystore “The_Name_Of_The_PFX_file.PFX” –destkeystore Name_For_The_Key_store.jks –srcstoretype PKCS12 – deststoretype JKS – jmj Apr 28 '10 at 6:19
  • now midlet is signed..but root certificate is not there in device i think as its showing domain as :"Untrusted" – jmj Apr 28 '10 at 6:20
  • i have installed its root certificate certificate.. using this symcaimport.redelijkheid.com/ now settings>security>certificates>godaddy>select use> there are three options server auth. cross certi. app signing among which app sign is disabled.. and when i install the app and click on it it shows invalid application "Delete ?" rot certificate i have installed is from certs.godaddy.com/anonymous/repository.seam Go Daddy Class 2 Certification Authority Root Certificate (DER Format) – jmj Apr 28 '10 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.