1

I have 3 Windows 10 computers on a LAN (A, B, C), connected with a DSL modem. I am trying to access shared folders from each computer. All computers (including A) can see B & C, but B & C cannot see A (A can see itself, with \\A). All computers are running Windows 10 version 1803. A and C are running OS build 17134.165 Pro, B is running 17134.228 Home. This problem only started happening with the latest major Windows update.

"Windows cannot access \\A" Error code: 0x80004005 Unspecified error.

Troubleshooting results in

"Windows can't communicate with the device or resource. It is available but not responding to connection attempts. A firewall or network security policy on the remote computer might be blocking the connection on port "file and print sharing resource"

.

"File and Printer Sharing" is checked for both private and public in Windows Defender Firewall -> Allowed apps. I also enabled group policy Computer Configuration -> Administrative Templates -> Network -> Network Connections -> Windows Firewall -> Domain Profile -> Windows Firewall: Allow inbound file and printer sharing exception (as per https://computerstepbystep.com/windows-firewall-allow-inbound-file-and-printer-sharing-exception.html) but it made no difference. I also tried turning off windows firewall, and it made no difference.

The computers "dial" a dsl connection (using rasdial) to get their own public IP address (but not dialing this connection doesn't solve the problem). The DSL connection is a "public" network, and the "Ethernet" connection is a private network.

Both the dsl and ethernet network adapters have "File and Printer Sharing for Microsoft Networks" and "Client for Microsoft Networks" installed and enabled.

Both Private and Guest or Public network profiles have "network discovery" & "file and printer sharing" turned on.

Pinging A from B & C works and shows the right (local) ip address. Trying to open that local ip address in windows explorer (\\192.168.2.11) behaves the same as trying to open \\A.

Subnet mask is the same for all computers.

The services "Function Discovery Resource Publication" and "UPnP Device Host" were not running on A, but starting them made no difference.

I tried to enable insecure guest logons (as per https://superuser.com/a/1326327/318722 and https://support.microsoft.com/en-us/help/4046019), but that did not change anything.

I also tried to enable SMB Direct (and even SMB 1.0/CIFS Client (server was already enabled)) on A, to no avail.

Here is the output of netsh interface ip show address (as per https://superuser.com/a/1230396/318722)

For A:

Configuration for interface "Bell"

DHCP enabled:                         No
IP Address:                           74.12.xxx.xxx
Subnet Prefix:                        74.12.xxx.xxx/32 (mask 255.255.255.255)
Default Gateway:                      0.0.0.0
Gateway Metric:                       1
InterfaceMetric:                      25

Configuration for interface "Wi-Fi"

DHCP enabled:                         Yes
InterfaceMetric:                      4250

Configuration for interface "Local Area Connection* 11"

DHCP enabled:                         Yes
InterfaceMetric:                      4250

Configuration for interface "Local Area Connection* 3"

DHCP enabled:                         Yes
InterfaceMetric:                      4250

Configuration for interface "Ethernet 2"

DHCP enabled:                         Yes
InterfaceMetric:                      4260

Configuration for interface "Bluetooth Network Connection"

DHCP enabled:                         Yes
InterfaceMetric:                      4290

Configuration for interface "Loopback Pseudo-Interface 1"

DHCP enabled:                         No
IP Address:                           127.0.0.1
Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
InterfaceMetric:                      4300

Configuration for interface "Ethernet"

DHCP enabled:                         Yes
IP Address:                           192.168.2.11
Subnet Prefix:                        192.168.2.0/24 (mask 255.255.255.0)
Default Gateway:                      192.168.2.1
Gateway Metric:                       0
InterfaceMetric:                      4250

and for B:

Configuration for interface "Bell"

DHCP enabled:                         No
IP Address:                           74.12.xxx.xxx
Subnet Prefix:                        74.12.xxx.xxx/32 (mask 255.255.255.255)
Default Gateway:                      0.0.0.0
Gateway Metric:                       1
InterfaceMetric:                      25

Configuration for interface "Wi-Fi"

DHCP enabled:                         Yes
InterfaceMetric:                      4250

Configuration for interface "Local Area Connection* 5"

DHCP enabled:                         Yes
InterfaceMetric:                      4250

Configuration for interface "Local Area Connection* 6"

DHCP enabled:                         Yes
InterfaceMetric:                      4250

Configuration for interface "Bluetooth Network Connection"

DHCP enabled:                         Yes
InterfaceMetric:                      4290

Configuration for interface "Loopback Pseudo-Interface 1"

DHCP enabled:                         No
IP Address:                           127.0.0.1
Subnet Prefix:                        127.0.0.0/8 (mask 255.0.0.0)
InterfaceMetric:                      4300

Configuration for interface "Ethernet"

DHCP enabled:                         Yes
IP Address:                           192.168.2.12
Subnet Prefix:                        192.168.2.0/24 (mask 255.255.255.0)
Default Gateway:                      192.168.2.1
Gateway Metric:                       0
InterfaceMetric:                      4250

I confirmed that SMB2 is running on both A & B with

Get-SmbServerConfiguration | Select EnableSMB2Protocol

as per https://www.windowscentral.com/how-access-files-network-devices-using-smbv1-windows-10, and it is.

  • Did you enable RDP settings for computer A and add B and C's names on it? – CAO Aug 24 '18 at 18:07
  • @CAO Yes, RDP is already enabled on A; I'm not sure what you mean by adding B & C - you mean like user accounts? I am able to connect to A from B & C using Remote Desktop (but not using Windows Explorer to access shared folders). – Jimmy Aug 24 '18 at 18:14
  • And in Network and Sharing Center>Advanced Sharing under Turn On Network Discovery have you checked the box next to "Turn on Automatic Setup of Network Devices"? (side note: I am on a Win 7 computer right now so I am telling you the option based on my memory, will be on win 10 in about 2 hours) – CAO Aug 24 '18 at 18:34
  • Yes, "turn on automatic setup of network connected devices" is also checked (only available for private networks) – Jimmy Aug 24 '18 at 19:50
0

If this showed up after a major update there could be permissions issues on the share that are getting in the way. Make sure both the share permissions and local NTFS permissions are set up to permit those other PCs to access it. The big Windows updates have a bad habit of resetting random settings to default.

You can also try temporarily disabling the firewall entirely to make sure it's not the issue, but it sounds like you've done a good job checking the network side.

  • Thanks for giving this some thought. Properties -> Advanced Sharing shows that the shared folder has the "Share this folder" checkbox checked; Permissions show that 'Everyone' has Read access to it. Is there anything else I should check? I did try turning off the firewall, didn't make a difference. – Jimmy Aug 24 '18 at 20:13
  • Had you checked Properties -> Security too so you could confirm those settings matched? Windows will go with whichever set is more restrictive so that could be part of it. Under Properties -> Security -> Advanced you can also make sure the owner of the folder is set to the right account and let all folders/files inherit whatever changes you make. – LostWander Aug 24 '18 at 20:50
  • Properties -> Security shows that A\Users have all permissions except full control & special permissions. Properties -> Security -> Advanced -> Permissions shows A\Users as having read & execute permissions. Properties -> Security -> Advanced -> Share shows that Everyone is allowed read permission. I might be wrong, but it seems that if folder permissions were the issue, I would at least be able to see the computer A from B/C's windows explorer? – Jimmy Aug 24 '18 at 21:39
  • Windows 10 has been really unreliable with having computers show up under "Network" in explorer, so it's possible that it's unrelated. They actually even completely removed the related Homegroup feature in an earlier update. Hopefully you found something in the meantime but all I can think of now is to try recreating the share entirely and making sure that connections from everyone are allowed – LostWander Aug 28 '18 at 13:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.