1

I have some files on an external hard drive. The drive is corrupted and I am currently in the process of recovering those files and transferring them from the E:\ drive (external USB drive) to the F:\ drive (a second external usb drive)

E: originally had a lot of programs on it (like everything from Microsoft Office, Adobe Suite, video games, etc)

I'm currently recovering the important files to the F:\ drive, but I have about 10 hours to wait. I decided not to recover a lot of the programs, and just re-download them.

I was able to re-download League of Legends no problem, and I want to put Gwent back on there. Gwent was originally located here:

E:\Games\Gwent\GOG Galaxy

So if I go into Uninstall Programs/Files, you can see that some of the icons are missing (these would be some programs on the E:\ drive).

If I try to uninstall this program by clicking on Uninstall, I get an error: "Windows cannot find 'E:\Games\Gwent\GOG Galaxy\Games\Gwent\unins000.exe'. Make sure you typed the name correctly, and then try again."

  1. I've tried to redownload this program from the internet through their website, but the GoG client won't allow me to change the directory. And the Gwent client won't allow me to click "Install". I have already contacted Customer Support about this. They told me to uninstall the program. >.>

I have also tried going into the Registry - I've looked into HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall and I can't find Gwent or GoG anywhere. (I went through each product key, one at a time, slowly, and I still don't see it)

I have also tried the Microsoft Install/Uninstall Program Fixer from https://support.microsoft.com/en-us/help/17588/fix-problems-that-block-programs-from-being-installed-or-removed but my program is not listed. If a program is not listed, it asks you for a Program Key... which is not available.

I have also tried using command prompt. I'm not that great with command prompt, but I've tried using E:\> takeown /f Games but I got ERROR: File ownership cannot be applied on insecure file systems; this is no support for ACLs.

I've tried icacls Games /grant administrator and I get: Invalid parameter "administrator"

I thought I could possibly wait for these files to finish recovering from E: to F:, and then format the E: drive, but I don't even know if that would work.

Any ideas?

NOTE: The ONLY visible folders on the E: drive are

  • EFI (I did not put this on here)
  • Recycle Bin (hidden)
  • System Volume Information (hidden)

All of the original files/folders on the E:\ drive are not accessible through a GUI. There are "there", but they are not visibly there. THerefore, I cannot simple navigate to E:\Games (through File Explorer) and click on the uninstall file.


EDIT: Long story short - When you uninstall a program (through normal means) you typically use Control Panel > Apps > Uninstall. The programs I'm trying to uninstall are located on my E:\ drive. (Not C:\Program Files). Some of these programs are located in E:\Games, and some are in E:\Programs.

The E: drive has been corrupted. I'm in the process of recovering files from E: and transferring them to F:. If I try to uninstall a program (through normal means) that is located in E:\Games or E:\Programs, I am unable to. (See lengthy explanation above)

  • Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. – Ramhound Aug 24 '18 at 21:52
  • I'm sorry but I don't understand how it can be any more detailed. I have included all of the necessary information: I'm trying to uninstall a program. I have outlined exactly how I would normally go about uninstalling a program. I have described why I cant uninstall it through normal means. I have also detailed steps I've tried to take to uninstall this program. What other information can I give? – MEE Aug 24 '18 at 22:12
  • You say you checked under: HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Uninstall but if this is a 32-bit app on a 64-bit OS, you may want to check under: HKEY_LOCAL_MACHINE\Software\wow6432node\Microsoft\Windows\CurrentVersion\Uninstall – HelpingHand Aug 24 '18 at 22:19
  • Unless these programs were always located on the E drive, which means moving Program Files to that drive (which while is possible is not actually supported) you shouldn't have to uninstall anything. You should just reinstall the programs to their new location. If the files are no longer there, then they can't be uninstalled, you can simply force the installation of those applications again. Without files like unins000.exe programs cannot be uninstalled, but since they no longer actually installed, you can just install them. – Ramhound Aug 24 '18 at 22:22
1

Solved by HelpingHand

Found the appropriate registry file in HKEY_LOCAL_MACHINE\Software\wow6432node\Microsoft\Windows\CurrentVersion\Uninstall

I was able to delete from the registry and re-download. (As described in my text wall, the GoG client doesn't allow you to select a new directory for a "new" installation, and the Gwent Client does not allow you to install if it detects an existing file. The only option is to uninstall. But since I cannot uninstall through traditional means, I had to find it in the registry.)

  • Alternatively, you could have tried going into control panel to uninstall the apps. I personally find the apps and settings route to be garbage. – DrZoo Aug 25 '18 at 1:24
  • As stated in my text wall, I could not Uninstall through normal means (ie: control panel) – MEE Aug 25 '18 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.